Support Matrices and Prerequisites

This topic lists the Eclipse IDE versions supported by the AccuRev Eclipse plugin. It also lists additional prerequisites.

Supported Eclipse versions: AccuRev plugin

The AccuRev Plug-In for Eclipse supports the following versions of Eclipse:

Plugin version Eclipse version
2019.2 4.6.x, 4.7.x, 4.8.x
2019.1 4.6.x, 4.7.x, 4.8.x
2018.3 4.6.x, 4.7.x, 4.8.x
2018.2 4.5.x, 4.6.x, 4.7.x
2018.1 4.5.x, 4.6.x, 4.7.x
2017.1 4.4.x, 4.5.x, 4.6.x
2016.1 4.3.x, 4.4.x, 4.5.x
2014.1 3.7.x, 4.2.x, 4.3.x
2013.5 3.6.x, 3.7.x, 4.2.x

We recommend Java 2 Runtime Environment 5.0 and higher. Versions 1.4.2 and higher are supported.

Back to top

Supported Eclipse versions: Git Feature

The Git plugin bundled with the AccuRev plugin for Eclipse supports the following versions of Eclipse:

Plugin version Eclipse version
2019.2 4.6.x, 4.7.x, 4.8.x
2019.1 4.6.x, 4.7.x, 4.8.x
2018.3 4.6.x, 4.7.x, 4.8.x
2018.2 4.5.x, 4.6.x, 4.7.x

Back to top

Prerequisites

Make sure the following prerequisites are met:

  1. Eclipse IDE must be updated with EGit-Git integrations for Eclipse from the marketplace. Even though version 4.5.x and 4.6.x of Eclipse comes bundled with the dependencies of EGit-Git integrations, it is required to have it updated.
  2. AccuRev 7.2 client.
  3. Git version 2.13.x and 2.14.x. AccuRev Git Client is incompatible with some recent Git releases. See the Known issues section for more details.

Back to top