Troubleshooting

Following are troubleshooting suggestions for issues relating to external authentication:

Problem:

SSO header and data are unknown.

Resolution:

  • Turn off External Authentication.

  • Add the DUMP_REQUEST_HEADERS site parameter with a value of Y and set the debug level for the site administration logs to Debug.

  • Enable External Authentication.

  • Try to log in to ALM Site Administration.

  • Check the Site Administration logs to see what data the Authentication server sent. Search for your user ID and identify the header that contains it. This header must be used in the External Authentication wizard.

    Note: To help find the entry in the Site Administration logs, filter the ERR entries and search for the exact time stamp associated with the error. You will see more info under the DBG entry.

  • Apply the correct header and pattern.

  • Once the problem is solved, turn off debug and set DUMP_REQUEST_HEADERS to N.

Problem:

Authentication to Site Administration failed due to an incorrect configuration.

Possible Cause:

  • User with SSO data was not added to the Site Administrators list.

  • Incorrect or missed SSO data in the user’s properties.

  • The pattern or header is incorrect.

Resolution:

  • Execute the following SQL query :

    UPDATE PARAMS SET PARAM_VALUE='N' WHERE PARAM_NAME='EXTERNAL_AUTH_MODE'
  • Restart ALM service.
  • Log in to Site Administration and verify the configuration.

    Information about the Site Administration schema and database can be found at siteadmin.xml, located in <ALM_INSTALLATION_FOLDER>\application\20qcbin.war\WEB-INF.

Problem:

Failed to log in to the CAC environment with HTTP error 502.

Possible Cause:

SSL is terminating on the OpenText Application Quality Management server, but the IIS URL Rewrite Rule contains an indicator for SSL offloading.

Resolution:

If the OpenText Application Quality Management server requires SSL, remove the HTTP_X_FORWARDED_PROTO server variable from the URL Rewrite Rule for qcbin.

Problem:

OpenText Enterprise Performance Engineering configuration fails with an Action not authorized message.

Possible Cause:

  • The OpenText Application Quality Management internal URL is incorrect.

  • The OpenText Enterprise Performance Engineering server internal URL is incorrect.

Resolution:

Ensure that the OpenText Application Quality Management internal URL and the OpenText Enterprise Performance Engineering server internal URL are correct.

Problem:

When you must apply a client certificate to a connection, for example when running VAPI-XP tests, the Select Certificate dialog box is not seen.

Possible Cause:

The Select Certificate dialog box is open, but is sometimes hidden.

Resolution:

Manually switch to the Select Certificate dialog box.

Problem:

When working with Smart Card authentication, the authentication screen appears when ALM makes an independent connection. For example, when the ALM Welcome page or the ALM Help opens, the authentication screen also appears.

Resolution:

Enter the required authentication information each time the authentication screen appears.

Problem:

When working with Smart Card authentication, the authentication screen appears when you open a new ALM session in a separate tab.

Resolution:

Enter the required authentication information in the new tab. You can avoid this issue by configuring the TabProcGrowth registry parameter.

Problem:

When saving an OpenText Application Quality Management session with Smart Card authentication using IIS, an error message appears and the session cannot be saved.

Resolution:

In IIS, increase the value of the uploadReadAheadSize parameter. The default value is 58 KB.