Getting more information from Graph Data

There are several techniques you can use in Analysis to enable you to effectively view the displayed data.

Determine a point's coordinates

To determine the coordinates and values at any point in a graph, place the cursor over the point you want to evaluate. Analysis displays the axis values and other grouping information.

Back to top

Drill down in a graph

Drill down enables you to focus on a specific measurement within your graph and display it according to the desired grouping.

  1. Right-click on a line, bar, or segment in the graph, and select Drill Down. The Drill Down Options dialog box opens, listing all of the measurements in the graph.

  2. Select a measurement for drill down.

  3. From the Group By box, select a group by which to sort.

  4. Click OK. Analysis drills down and displays the new graph.

    • To undo the last drill down settings, right-click and select Undo Set Filter/Group By from the context menu.

    • To perform additional drill-downs, repeat steps 1 to 4.

    • To clear all filter and drill down settings, right-click and select Clear Filter/Group By from the context menu.

Back to top

Filter the data

This task describes how to filter the data and create custom filters.

  1. In the Legend window, click the column header of the measurement you want to use as a base for the filter.

  2. To show a single entry, expand the drop-down list and select that entry.

  3. To create a custom filter, select Custom in the drop-down list. The Custom Filter dialog box opens.

  4. Select an evaluation expression and provide a value. To use wildcards, use an underscore (_) to represent a single character and % for multiple characters. For details, see Custom Filter Dialog Box.

  5. To provide additional criteria, select a logical operator, AND or OR and set up the second expression.

Back to top

Change the granularity of the data

This task describes how to change the granularity of a graph.

  1. Click inside a graph.

  2. Select View > Set Granularity, or click the Set Granularity button . The Granularity dialog box opens.

  3. Enter the granularity of the x-axis and select a time measurement. The maximum granularity is half of the graph's time range.

  4. To ensure readability and clarity, LoadRunner automatically adjusts the minimum granularity of graphs with ranges of 500 seconds or more.

  5. Click OK.

Back to top

View measurement trends

This task describes how to activate the View Measurements Trends option from a line graph.

  1. Select View > View Measurement Trends, or right-click the graph and choose View Measurement Trends. Alternatively, you can select View > Configure Measurements and check the View measurement trends for all measurements box.

  2. Note: The standardization feature can be applied to all line graphs except the Web Page Diagnostics graph.

  3. View the standardized values for the line graph you selected. The values in the Minimum, Average, Maximum, and Std. Deviation legend columns are real values.

 

To undo the standardization of a graph, repeat step 1.

Note: If you standardize two line graphs, the two y-axes merge into one y-axis.

Back to top

Auto correlate measurements

You can detect similar trends among measurements by correlating a measurement in one graph with measurements in other graphs. Correlation cancels the measurements' actual values and allows you to focus on the behavior pattern of the measurements during a specified time range of the load test scenario.

  1. From a graph or legend, right-click the measurement you want to correlate and choose Auto Correlate. The Auto Correlate dialog box opens with the selected measurement displayed in the graph.

  2. Select a suggested time range method and time range.

  3. If you applied a time filter to your graph, you can correlate values for the complete scenario time range by clicking the Display button in the upper right-hand corner of the dialog box.

  4. To specify the graphs you want to correlate with a selected measurement and the type of graph output to be displayed, perform the following:

    • Select the Correlation Options tab.

    • Select the graphs to correlate, the data interval, and output options, as described in Drill Down Options Dialog Box.

    • On the Time Range tab, click OK. Analysis generates the correlated graph you specified. Note the two new columns—Correlation Match and Correlation—that appear in the Legend window below the graph.

  5. To specify another measurement to correlate, select the measurement from the Measurement to Correlate box at the top of the Auto Correlate dialog box.

    The minimum time range should be more than 5% of the total time range of the measurement. Trends which are smaller than 5% of the whole measurement will be contained in other larger segments.

    Sometimes, very strong changes in a measurement can hide smaller changes. In cases like these, only the strong change is suggested, and the Next button is disabled.

    Note: This feature can be applied to all line graphs except the Web Page Diagnostics graph.

Back to top

Save graph as image

You can save a graph as an image file.

  1. Right-click the graph and select Save as image.
  2. In the Save as Image dilaog box, select the type of image (.jpeg/.png).
  3. Select the location to save the file and click Save.

Back to top