How to Work with Results in ALM - With Performance Center

ALM servers with Performance Center, allow you to perform the following operations.

Open an existing Analysis Session file

  1. Select Tools > ALM Connection and make sure your connection to ALM is open.

  2. Select File > Open.

  3. Drill down to the Run level within the Test Plan module, and select an individual run.

  4. Select a zip file containing the Analysis session file.

  5. Click Open.

Back to top

Open raw data and create a new Analysis session

  1. Select Tools > ALM Connection and make sure your connection to ALM is open.

  2. To create a new Analysis session file from the raw data, select File > New.

  3. Drill down to the Run level within the Test Plan module, and select an individual run.

  4. Select a zip file containing the run's raw data.

  5. Click Open.

Back to top

Save the changes to the Analysis session file

  1. Complete your changes to the Analysis results.

  2. Select Tools > ALM Connection and make sure your connection to ALM is open.

  3. Select File > Save.

  4. To save an Analysis session that was opened from the file system, click the Test Lab module button.

  5. Drill down to the Run level within the Test Plan module, and specify a name for the zip file.

  6. Provide a comment about the Analysis session (optional).

  7. Click Save.

Back to top

Save the Analysis session file to a new ALM location

  1. Select Tools > ALM Connection and make sure your connection to ALM is open.

  2. Open an Analysis session file from the file system, or from ALM as described above.

  3. Select File > Save as.

  4. Drill down to the Run level within the Test Plan module, and select an individual run.

  5. Specify a name for the Analysis session zip file. The name Results is reserved.

  6. Provide a comment about the Analysis session (optional).

  7. Click Save.

Back to top

Integration Methods - TestPlan or TestLab

Analysis uses different integration methods for ALM projects with Performance Center extensions, depending on how it was invoked:

  • Through the Web-interface or from Controller—TestPlan integration is used.
  • Through a manual launch, connected to a project through the ALM Connection dialog box—TestLab integration is used.

Back to top

See also: