ALM (Application Lifecycle Management) integration

In this topic:

Manage results using ALM overview

LoadRunner Analysis works together with Application Lifecycle Management (ALM). ALM provides an efficient method for storing and retrieving scenario and analysis results. You can store results in an ALM project and organize them into unique groups.

In order for the Analysis to access an ALM project, you must connect it to the web server on which ALM is installed. You can connect to either a local or remote web server.

For more information on working with ALM, see the ALM Help Center (select the relevant version).

For information about integrating with LoadRunner Enterprise (formerly Performance Center), see LRE integration with Analysis.

Back to top

Connect to ALM from Analysis

To store and retrieve Analysis results from ALM, you need to connect to an ALM project. You can connect or disconnect from an ALM project at any time during the testing process.

You can connect to one version of ALM from Analysis and a different version from your browser. For more information, see the Important Information section in ALM Connection dialog box.

To connect to ALM:

  1. Select Tools > ALM Connection. The ALM Connection dialog box opens.

  2. Enter the required information in the ALM Connection dialog box, as described in ALM Connection dialog box.

  3. To disconnect from ALM, click Disconnect.

Note:  

  • There is no explicit option in the Analysis user interface for enabling CAC mode (as in VuGen). Analysis automatically enables CAC mode if the ALM server machine supports it.

  • If you have a slow connection to ALM, this may be because the Analysis machine does not have access to the WAN, and so cannot verify the digital signature of the relevant files.

    Resolution: Download and import the certificates from https://support.globalsign.com/customer/portal/articles/1426602-globalsign-root-certificates using certmgr MMC until the issue is resolved (you might not need to import all the certificates). This information is also available in a knowledge base article.

Back to top

Work with results in ALM

The following steps describe the workflow for working with results saved in an ALM project.

  1. Connect to ALM.

    Open a connection to the ALM server and project that contains the LoadRunner Professional result or Analysis session files. For task details, see Connect to ALM from Analysis.

  2. Open an existing Analysis session file - optional.

    1. Select File > Open.
    2. In the left pane select a script.

    3. In the right pane, select the results for which the Analysis session file was created.

    4. Click OK.
  3. Create a new Analysis session file from the raw data - optional.

    This procedure describes how to create a new Analysis session file on the ALM server, from the raw results file. If an Analysis session file already exists for the raw data, you can choose to overwrite the existing file.

    1. Select File > New.
    2. In the left pane select a script.

    3. In the right pane, select the results you want to analyze.

    4. Click OK.

  4. Save the LoadRunner Professional results file.

    When you are finished analyzing your results and creating reports or graphs, save the changes. Select File > Save. The Analysis session file is in the ALM project.

Back to top

ALM Connection dialog box

This dialog box enables you to connect to an ALM project.

To access Tools > ALM Connection
Important information

You can connect to one version of ALM from LoadRunner Professional and a different version of ALM from your browser.

You can only connect to different versions of ALM if one of the versions is ALM 11.00 or higher.

Note: Before you connect to ALM through the LoadRunner Professional interface, it is recommended that you first connect to the ALM server through your browser. This automatically downloads the ALM client files to your computer.

Relevant tasks Connect to ALM from Analysis

User interface elements are described below:

UI Element Description
Step 1: Connect to Server
  • Server URL. The URL of the server on which ALM is installed. The URL must be in the following form http://<server_name:port>/qcbin.
  • Reconnect to server on startup. Automatically reconnect to the server every time you start LoadRunner Professional .
  • / . Connects to the server specified in the Server URL box. Only one button is visible at a time, depending on your connection status.
Step 2: Authenticate User Information
  • User Name. Your ALM project user name.
  • Password. Your ALM project password.
  • Authenticate on startup. Authenticates your user information automatically, the next time you open the application. This option is available only if you selected Reconnect to server on startup above.
  • . Authenticates your user information against the ALM server.
  • After your user information has been authenticated, the fields in the Authenticate user information area are displayed in read-only format. The Authenticate button changes to .

    You can log in to the same ALM server using a different user name by clicking Change User, entering a new user name and password, and then clicking Authenticate again.

Step 3: Login to Project
  • Domain. The domain that contains the ALM project. Only those domains containing projects to which you have permission to connect to are displayed.
  • Project. Enter the ALM project name or select a project from the list. Only those projects that you have permission to connect to are displayed.
  • Login to project on startup. This option is only enabled when the Authenticate on startup check box is selected.
  • / . Logs into and out of the ALM project.

Back to top