New Scenario dialog box

This dialog box enables you to create a new scenario and select Vuser scripts or test modules to run in the scenario.

Access the dialog box

You can access this dialog box in the following ways.

  • File > New in the Controller window
  • New Scenario toolbar button
  • Open the Controller (If the Show New Scenario Dialog at startup option is enabled)

Back to top

New Scenario user interface elements

The New Scenario dialog box lets you set up your scenario using the following user interface elements:

UI Element
Description
Scenario Type
Before you create a scenario, you should have a good idea as to the type of scenario you want to create. For details, see Introducing Controller.
  • Manual Scenario. You manually build the scenario creating Vuser groups and specifying the script, load generators, and the number of Vusers to include in each Vuser group using one of the following modes:

    • By Number Indicate the total number of Vusers. In this mode, each script you select for the scenario is assigned to a Vuser group. You assign a number of Vusers to each Vuser group that you create.
    • By Percentage Distribute the Vusers among the scripts.

      Note: You can convert scenarios from one mode to another at any time. For details, see Change the scenario mode (manual scenario).

  • Goal-Oriented Scenario. You define the goals you want your test to achieve, and LoadRunner Professional automatically builds a scenario for you, based on these goals.

Opens the Add Scripts dialog box, where you can choose Vuser scripts or test modules for your scenario. For details, see Add Scripts user interface elements.
Opens VuGen so that you can record a Vuser script. For details, see How to Record a Vuser Script.

Opens the Connection to ALM dialog box, where you can connect to Application Lifecycle Management to download scripts.
Removes the selected script or module from the script list. Tip: Multiple selection is supported.
<script list> A list of the scripts that were added to the scenario, by name and type.
Show at startup
When selected, the New Scenario dialog box is displayed when you open the Controller.

Note: This option can also be enabled/disabled from Controller's View menu. Select View > Show New Scenario Dialog at startup.

Back to top

Add Scripts user interface elements

The Add Scripts dialog box lets you choose a script or test module for your scenario.

UI Element
Description
Script Type
The type of test to use in the scenario:
  • LoadRunner Scripts. Scripts created with Micro Focus tools, such as VuGen and DevWeb. VuGen scripts have a .usr extension, and DevWeb scripts have a .js extension.
  • System or Unit Tests. NUnit, JUnit, or Selenium test modules created within an external application, such as Visual Studio or Eclipse. These must be files with .dll, .jar, or .class extensions.
  • JMeter Scripts. Scripts created with Apache JMeter, with a .jmx extension. For details, see JMeter tests.
  • Gatling Scripts. Scripts created with Gatling, with a .scala or .jar extension. For details, see Gatling tests.
  • Selenium Scripts. Java scripts created with Selenium, with a .java extension. For details, see Selenium tests. Note: This option is a technical preview.
Browse Lets you locate the script or unit test.
Removes the selected script or module from the script list.
Searches for a script or test by its name or path. The search starts as soon as you begin to type.
<script list> A list of the scripts that can be added to the scenario. Clear the check box by the scripts that you want to exclude.
Add Adds the selected scripts to the scenario and closes the window.

Next steps: