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Welcome to This Guide
Welcome to the OpenText™ LoadRunner Enterprise Quick Start.

LoadRunner Enterprise is a Web-enabled global performance testing tool,
designed to streamline the testing process and increase the test efficiency for
multiple concurrent performance tests across multiple geographic locations.

This Quick Start is a self-paced guide designed to lead you through the process of
creating, running, and analyzing a performance test, and to introduce you to the
LoadRunner Enterprise testing environment.

Note: This guide assumes that your LoadRunner Enterprise environment has
been fully installed and configured, and that a domain and project have been
set up. For details, contact your LoadRunner Enterprise administrator.

How This Guide is Organized
This guide contains the following lessons:

Lesson Description

"Introducing
LoadRunner
Enterprise" on
page 7

Provides an overview of LoadRunner Enterprise and the
performance testing applications.

"Creating Vuser
Scripts" on page 9

Describes the steps involved in recording Vuser scripts
using Virtual User Generator.

"Creating and
Designing
Performance
Tests" on page 15

Describes the steps involved in creating and designing
performance tests.

"Running
Performance
Tests" on page 23

Describes the steps that are necessary before running a
performance test, and how to begin a test run.
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Lesson Description

"Post-Run Analysis
and Trending" on
page 28

Describes how to analyze test run data using LoadRunner
Analysis, and how to view performance improvements and
regressions using the Trend Reports feature.
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Introducing LoadRunner Enterprise
This lesson provides a brief overview of LoadRunner Enterprise, and of the
applications that are involved in the testing process.

Notes:
l The Quick Start describes how to run a performance test with a single host
functioning as both a Controller and a load generator (C+LG). However,
due to possible heavy load on the Controller and load generator hosts
during a performance test, it is best practice to assign these functions to
separate host machines.

l Ensure that the latest standalone versions of Virtual User Generator
(VuGen) and LoadRunner Analysis are installed on your system.

In this lesson you will learn about:

l " LoadRunner Enterprise Testing Process" below
l "Performance Testing Applications" on the next page

LoadRunner Enterprise Testing Process
Using LoadRunner Enterprise, you create performance tests in which you define
the events that occur during a testing session. During a test, LoadRunner
Enterprise replaces human users at physical machines with virtual users, or
Vusers. These Vusers create load on your system by emulating actions of typical
users in a repeatable and predictable manner.

What is the testing process?
The testing process consists of the following basic processes:

l Creating the script. Capturing typical end-user business processes performed
on your application.

l Designing the performance test. Setting up the test environment by defining
events that occur during the testing session.

Quick Start
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l Preparing to run the performance test. Adding the performance test to a test
set and reserving a timeslot for the test.

l Running the performance test. Driving, managing, and monitoring the test.
l Analyzing the results and viewing performance trends. Analyzing the
performance data generated during the test run, and viewing trending
information which identifies performance improvements and regressions over
time.

These processes are explained in more detail in the lessons that follow.

Performance Testing Applications
Each step in the testing process is carried out by one of the performance testing
tool components. The components are as follows:

Application Description

Virtual User
Generator
(VuGen)

Creates the script and generates virtual users, or Vusers. VuGen
does this by capturing actions that typical end-users would
perform on your application, and then records these actions into
automated Vuser scripts. These Vuser scripts form the
foundation of a performance test.

LoadRunner
Enterprise

Provides the central console from which you build, manage, and
monitor a test.

Analysis Analyzes the performance test and provides graphs and reports
with in-depth performance analysis information. Using these
graphs and reports, you can pinpoint and identify the
bottlenecks in your application and determine what changes
need to be made to your system to improve its performance.

Quick Start
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Creating Vuser Scripts
This lesson explains the steps involved in recording Vuser scripts using Virtual
User Generator.

In this lesson you will learn about:

l "Recording Vuser Scripts" below

Recording Vuser Scripts
You record Vuser scripts using Virtual User Generator (VuGen). A Vuser script is a
record of a typical end-user business process. VuGen works on a record-and-
playback principle. As you walk through a business process on your application,
VuGen records your actions into an automated script which later forms the
foundation of the performance test.

This section includes:

l "How do I start recording user activity?" below
l "How do I record a script?" on the next page
l "How do I view my script?" on page 11
l "How do I save the script?" on page 14

How do I start recording user activity?
You begin by opening Vugen and creating a blank script.

1. Start VuGen.

Double-click the Virtual User Generator shortcut icon on your desktop.

The VuGen Start Page opens.

2. Create a blank Web script.

a. In the toolbar above the VuGen Start Page, click the Add New Script button
. The Create a New Script dialog box opens.

Quick Start
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A protocol is the language that your client uses to communicate with the
back end of the system.

b. Make sure the Category type is Single Protocol. VuGen displays a list of the
protocols that are available for a single-protocol script.

c. From the list of available protocols, select a protocol (example: for a Web-
based application, selectWeb - HTTP/HTML) and click Create. VuGen
creates a blank Vuser script and displays the script in the VuGen Editor.

How do I record a script?
The next stage in creating user emulation is recording the events performed by a
real user. In the previous section, you created an empty script. In this section, you
will record a script.

Note: The following exercise explains how to record a scripts for a Web-
based application (Web - HTTP/HTML).

1. Start recording.

a. Click the Record button on the VuGen toolbar. The Start Recording

dialog box opens.

b. In the Record into action box, select Action.
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c. In Record, selectWeb Browser.

d. In the URL address box, enter the URL address on the Web application
under test.

e. Keep all other default settings.

f. Click Start Recording. A new web browser opens and displays the Web
application under test.

The floating Recording toolbar opens.

2. Record your script.

Navigate through your Web application.

3. Stop recording.

Click the Stop Recording button on the floating toolbar to stop the recording

process.

VuGen generates the required code and inserts the code into the Vuser script.

How do I view my script?
VuGen recorded your steps from the moment you clicked the Start Recording
button to the moment you clicked the Stop Recording button. You can now use
VuGen to view the script.

1. Display the Solution Explorer tab.

Make sure the Solution Explorer tab is selected.
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This tab provides you structured access to the different parts of a Vuser script,
as well as to a number of files that are associated with the Vuser script.

2. Display the Step Navigator tab.

Click the Step Navigator tab.
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The Step Navigator displays an icon-based view of the script that lists the
actions of the Vuser as steps. For each action you performed during recording,
VuGen generated a corresponding step in the Step Navigator.

The Step Navigator displays a snapshot icon to indicate that a specific step
contains a snapshot.

3. View a step in the VuGen Editor.

Make sure Tools > Options > Editor> General > Show Class\Function
Browser is selected in the VuGen Editor.

Double-click any step in the Step Navigator to display the corresponding
function in the VuGen Editor. The Editor displays a text-based view of the script.
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In the Editor, the actions of the Vuser are listed as API functions. VuGen uses
color-coding to show the functions and their argument values in the script. You
can enter C or API functions, as well as control flow statements, directly into the
script.

How do I save the script?
Select File > Save Script As and save the script locally on your desktop. For
example, enter Scripts. The script file should be zipped. After you have created
your performance test, you will upload the script to LoadRunner Enterprise.
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Creating and Designing Performance
Tests
This lesson explains how to manage test assets in LoadRunner Enterprise, and the
steps involved in creating and designing a performance test.

In this lesson you will learn about:

l "Logging in to LoadRunner Enterprise" below
l "Adding Vuser Scripts to LoadRunner Enterprise" on the next page
l "Monitoring Performance Tests" on page 17
l "Creating Performance Tests" on page 18
l "Designing Performance Tests" on page 19

Logging in to LoadRunner Enterprise
You log into LoadRunner Enterprise as follows:

1. Open your web browser and enter the LoadRunner Enterprise Server URL
http://<LoadRunner Enterprise server name>/loadtest.

Note: If more than one LoadRunner Enterprise server is installed in your
system together with a load balancer, you should access LoadRunner
Enterprise by entering the load balancer's URL. Alternatively, you can
also enter the server's defined internal URL.

2. The LoadRunner Enterprise Login window opens.

If LoadRunner Enterprise was configured for external authentication (SSO), the
Login and Password fields do not appear in this window and you should be
redirected to your identity provider’s login screen.

3. In the Login box, enter your user name.

4. In the Password box, enter the password assigned to you by your site
administrator.
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5. Select the Automatically log in to my last domain and project on this
machine check box if you want LoadRunner Enterprise to automatically log in
to the last project in which you were working.

6. Click the Authenticate button. LoadRunner Enterprise verifies your user name
and password and determines which domains and projects you can access. If
you specified automatic login, LoadRunner Enterprise opens.

7. In the Domain list, select a domain. By default, the last domain in which you
were working is displayed.

8. In the Project list, select a project. By default, the last project in which you
were working is displayed.

9. Click Login. LoadRunner Enterprise opens.

Adding Vuser Scripts to LoadRunner
Enterprise
The first step in your test design process is to add your Vuser script to LoadRunner
Enterprise. Adding the script involves two steps: Creating a scripts folder, and
uploading the script to the folder.

How do I upload the Vuser Script?
You upload the script from within LoadRunner Enterprise, as follows:

1. Make sure the script is saved locally and is zipped.

2. In the top banner, click the module name or the dropdown arrow and
select Test Management > Tests & Scripts.

3. Create a script folder.

a. Select Subject.

b. Click New Folder, and specify a name for the folder, for example,

Scripts.

c. Click OK to add the folder.
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4. On the module toolbar, click Upload Script. The Upload Scripts dialog box

opens.

5. In the Select Folder box, select the scripts folder you created above.

6. Click the Select button and go to the location of the zipped script file.

7. Click Upload to upload the script.

Monitoring Performance Tests
You monitor performance test runs using the LoadRunner Enterprise online
monitors.

For example, you use the System Resource monitors to monitor a machine's
system resource usage during a performance test and identify server performance
bottlenecks.

A primary factor in a transaction's response time is its system resource usage.
Using the LoadRunner Enterprise resource monitors, you can monitor the Windows
Resource usage on a machine during a test run, and determine why a bottleneck
occurred on a specific machine.

What is a monitor profile?
To monitor server resources during the test, you select the type of monitors to run
and the servers whose resources you want to monitor. You then add the
measurements to monitor for each server. These monitor settings can be saved as
a monitor profile which can be used by any performance test in your project.

The following section shows you how to create a monitor profile and how to add a
Windows Resource Monitor to it.

How do I create a monitor profile?
You create and configure monitor profile as follows:

1. In the top banner, click the module name or the dropdown arrow and select
Monitors (under Assets).
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2. Create a folder for the monitor profile.

3. Select the folder, and click the New Monitor Profile button. The New

Monitor Profile dialog box opens, enabling you to add a new monitor profile.

4. SelectMonitor Profile, and enter the required information and click OK to add
the monitor profile to the folder.

5. In the Monitor Profile page, click New Monitor . In the Add NewMonitor page

that opens, you can select the monitors that you want to run.

6. Select theWindows Resourcesmonitor type and click Next.

7. Enter the server details and then click Get Counters to display a list of
available metrics and counters.

8. Select the measurements that you want to monitor, and then click to add the

counters to the Selected Counters table.

9. Click Save. The monitor is added to your monitor profile.

You add the monitor profile to the test as part of the test design process.

Creating Performance Tests
To create a test, you begin by creating a test folder, and then creating the test and
adding it to the folder. In the next section, you will learn how to design the test in
the Test Designer.

How do I create a performance test?
You create the test as follows:

1. In the top banner, click the module name or the dropdown arrow and
select Test Management > Tests & Scripts.
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2. In the test management tree, select the Subject root folder, click New Folder
. Enter a folder name and click OK.

3. Select the folder from the tree.

4. Click New Test . Fill in the fields in the Create New Performance Test dialog

box.

Designing Performance Tests
You design your performance test in the Performance Test Designer.

How do I open the Performance Test Designer?
You open the test designer as follows:

1. In the top banner, click the module name or the dropdown arrow and
select Test Management > Tests & Scripts.

2. Select the test you created above, and click the Edit Test button on the
toolbar. The Performance Test Designer opens.

How do I design the performance test?
From the Groups and Workload view in the Performance Test Designer, you
perform the basic test design steps. You design the test as follows:

1. Assign a Controller to the test.

a. Click the dropdown arrow adjacent to the Controller box (in the Summary
pane). The Select Controller dialog box opens.

b. Select Specific.

c. Select from the list the host machine that has been assigned the Controller
and Load Generator (C+LG) purpose.

2. Add Vuser scripts.

a. In the Groups pane, click Add Group . The Add Group dialog box opens,

displaying the Scripts tree with the script that you uploaded previously to
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LoadRunner Enterprise.

b. Select the script and click Add to add it to the test. The script appears in the
Groups pane.

3. Add load generators.

a. From the Groups pane toolbar, click Assign LGs.

The Assign Groups to Load Generators dialog box opens.

b. In the Groups column, select the Vuser groups to use in the test.

c. In the Load Generators column, select the Specific tab, and from the list
that appears, select the host machine that has been assigned the Controller
and load generator (C+LG) purpose.

d. Click Apply Assignment.

4. Configure the schedule settings.

A schedule defines the actions of the Vusers for the performance test run, for
example the behavior of 10 Vusers emulating 10 users simultaneously logging
on to the sameWeb site.

Because typical users do not perform the same action simultaneously, the
Scheduler allows you to schedule a performance test according to a more
realistic portrayal of typical user behavior.

Define the schedule as follows:

Quick Start
Creating and Designing Performance Tests

LoadRunner Enterprise (24.1-24.3) Page 20 of 38



In the Scheduler pane of the Groups and Workload tab, click in each of the
schedule actions in the Actions grid and define them as follows:

l Initialize.

l Start Vusers.

l Duration.

l Stop Vusers.

The schedule graph displays a graphical representation of the defined
schedule. The lines in the graph correspond to the actions defined in the
Actions grid.

How do I add the monitor profile to the test?
You add the monitor profile to the test as follows:

1. In the top banner, click the module name or the dropdown arrow and
select Test Management > Tests & Scripts.
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2. In the test management tree, select the test that you created in "How do I
create a performance test?" on page 18 and click Edit Test.

3. In the Performance Test Designer window, click the Assets tab and select
Monitors.

4. Click Assign Monitors. From the Monitor tree, select the monitor profile and

click Select & Close to add it to the test.
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Running Performance Tests
This lesson explains the steps that are necessary before you run the performance
test, and how to begin a test run.

In this lesson you will learn about:

l "Creating Test Sets" below
l "Reserving Timeslots" on the next page
l "Running Performance Tests" on page 25

Creating Test Sets
The next step in the performance testing process is the creation of a performance
test set.

What is a test set?
After you design the performance test in the Testing module, you organize the test
run by creating a test set, and adding an instance of the test to the test set. The
purpose of a test set is to enable you to group together tests that were created for
similar goals.

How do I create a test set?
You create the test set and add the test to it as follows:

1. Create the test set.

a. In the Performance Test Designer, click Save and Run. The Manage Test
Sets dialog box opens.

Tip: You can also create or assign a test set from the Create New
Performance Test dialog box. For details, see "How do I create a
performance test?" on page 18
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b. Click the Root test set folder, and click the New Folder button. Specify a

name for the Test Set folder, for example, Test_set_folder.

2. Assign the performance test to the test set.

a. Select the folder you created above, and click the New Test Set button.

b. Enter the test set name, for example, My_Test_Set. Click Assign. Your test is
assigned to the test set.

Reserving Timeslots
Before you run the test, you reserve a timeslot to ensure that the resources
needed are available for the duration of the test.

How do I reserve a timeslot?
1. In the top banner, click the module name or the dropdown arrow and select
Timeslots (under Resources).

2. From the calendar or grid view, click New/Add Timeslot. The Add New

Timeslot dialog box opens.

3. Define the following information:
l Start. ChooseManually as the method for running tests. The timeslot
reservation reserves testing resources only.

l Name. Enter a name for the timeslot.
l Test/Test Instance. Select the test you created and the test set instance to
link to the timeslot. The number of Vusers and hosts that were defined as part
of the test design process are automatically displayed.

l Duration. Set the start time, and enter a duration for the test.
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l Post Run Action. If the administrator did not set an action across the project
(the options are available for selection), select Collate and Analyze.

4. Click Calculate Availability. The availability of the requested resources during
the selected timeslot is calculated. The results of this calculation are displayed
in the Timeslot Status tab and graphically on the time chart.

Note: If the timeslot cannot be reserved, reselect your resources or
adjust the start time, taking into account the reasons displayed in the
Timeslot Status tab.

5. When you find a valid timeslot, click Add to save the timeslot.

Running Performance Tests
Now that you have designed the performance test, added an instance of the test
to a test set, and reserved a timeslot for the test, you are ready to run the test and
observe how your application performs under load.
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How do I run the performance test?
You run the performance test as follows:

1. In the top banner, click the module name or the dropdown arrow and
select Test Management > Tests & Scripts.

2. Select your test in the test management tree.

3. Click the Run Test button. The Run Performance Test dialog box opens.

4. Click the Reserved Timeslot tab.

5. Select the timeslot you reserved, and click Run.

The Initializing Run page displays the performance test initialization steps
performed by LoadRunner Enterprise, and the status for each step. If each step
is completed successfully, the performance test starts running and the Run
Dashboard opens. The Test Run page enables you to manage and monitor the
test as it runs.

What does the Run Dashboard display?
The Run Dashboard is the control center from which the test run is managed and
monitored.
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The Run Dashboard displays the following:

Pane/Tab Description

Summary The Summary pane at the top of the page displays a synopsis of
the running performance test.

Test run
views

Beneath the Summary pane is the Test Run Details area which
provides four views:
l Graphs. This is the view displayed in the above image. This view
displays performance measurements for those resources being
monitored in the test. This enables you to monitor how the
application under test is performing in real time and identify
where potential bottlenecks exist.

l Groups. The Groups view displays the statuses of the Vusers in
each Vuser group in the performance test.

l Transactions. The Transactions view displays how many
transactions have been run successfully or unsuccessfully.

l Messages. The Messages view displays error, warning, debug,
and output messages that are sent to the Controller by the
Vusers and load generators during a test run.

l Monitors. The Monitors view displays monitors from all the
monitor profiles and over firewall agents that are associated with
the selected test. You can add new monitors to the test from this
view.

Tabs On the right of the graphs pane, clickMore and select Graphs. A
list of the configured online graphs is displayed. You can select
which graphs to display in the Graphs view.
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Post-Run Analysis and Trending
This lesson explains how to analyze test run data using LoadRunner Analysis, and
how to view performance improvements and regressions using the Trend Report
feature.

In this lesson you will learn about:

l "Analyzing Performance Test Run Results" below
l "Viewing Performance Improvements and Regressions" on page 34

Analyzing Performance Test Run Results
Now that you have completed running the performance test, you can use
LoadRunner Analysis to analyze the performance data generated during the test
run. Analysis gathers the performance data into detailed graphs and reports. Using
these graphs and reports, you can pinpoint and identify the bottlenecks in the
application, and determine what changes need to be made to the system to
improve its performance.

How do I view Analysis information?
l To view Analysis data for your actual performance test, you perform the
following steps:

a. Install Analysis

You can download Standalone Analysis from the In the top banner, click the
module name or the dropdown arrow and select Download Applications >
Standalone Analysis.

b. Collate and analyze the results for the test run.

i. In the top banner, click the module name or the dropdown arrow and
select Test Runs. Select the performance test you just ran in the test
management tree, and click the Runs tab.
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ii. If the test run is in the Before Collating Results state, right-click the run,
and select Collate. The results for the test run are collated.

iii. When result collation has finished, and the test run is in the Before
Creating Analysis Data state, right-click the run, and select Analyze.

iv. When LoadRunner Enterprise has finished analyzing the results,
download the Results_<#>.zip file for the test run.

c. Open the Analysis session file for your performance test.

i. In Analysis, select File > Open. The Open Existing Analysis Session
dialog box opens.

ii. Click File System, and go to the Results_<run_id>.zip file for the
instance of your performance test that you want to analyze.

iii. Double-click the Results_<run_id>.zip file. The Analysis session file is
opened in Analysis.

For information about how to work within Analysis, see the LoadRunner
Professional Help Center.

Did I reach my goals?
Analysis opens displaying the Summary Report. The Summary Report provides
general information about the performance test run. In the Statistics Summary of
the report, you can see how many Vusers ran in the test and view other statistics
such as the total/average throughput, and the total/average hits. The Transaction
Summary of the report lists a summary of the behavior of each transaction.

How can I view the graphs?
The graph tree in the Analysis window shows the graphs that are open for viewing.
From the graph tree, you can choose to open new graphs and remove graphs that
you no longer want to view. The graphs are displayed in the graph viewing area in
the right pane of the Analysis window. You can view data from the selected graphs
in the graph legend.
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As an example, let's analyze the Average Transaction Response Time graph. Using
this graph, you can view the behavior of the problematic transactions during each
second of the performance test run. In this section, you view the behavior of the
check_itinerary transaction.

To open and analyze the Average Transaction Response Time graph:

1. Choose Graph > Add New Graph. The Open a New Graph dialog box opens.

2. Under Transactions, select Average Transaction Response Time.
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3. Click Open Graph. The Average Transaction Response Time graph opens in
the graph viewing area.

Click Close to exit the Open a New Graph dialog box.

4. In the legend, click check_itinerary. The check_itinerary transaction is
highlighted in the graph and in the legend below the graph.

Notice how the average response time of the check_itinerary transaction
fluctuates greatly compared to the other transactions at the bottom of the
graph, which follow a more or less stable average response time.
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How can I compare data from different graphs?
You can join two graphs together to see the effect of one graph's data on another
graph's data. This is called correlating two graphs. For example, you can correlate
the Running Vusers graph with the Average Transaction Response Time graph to
see the effect of a large number of Vusers on the average response time of the
transactions.

1. Choose Graph > Add New Graph. The Open a New Graph dialog box opens.

2. Under Vusers, select Running Vusers.

3. Click Open Graph. The Running Vusers graph opens in the graph viewing area.

Click Close to exit the Open a New Graph dialog box.

4. Select the Running Vusers graph and click theMerge Graphs button on

the main toolbar.

5. From the Select graph to merge with list, select Average Transaction
Response Time.

6. In the Select type of merge area, select Correlate, and click OK.

The Running Vusers and Average Transaction Response Time graphs are now
represented by one graph which opens in the graph viewing area.
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Another Analysis tool, Auto Correlate (click ), merges all graphs containing

data that could have had an effect on a transaction. Correlations of the transaction
with each element are displayed, allowing you to deduce which elements had the
greatest effect on the transaction.

How can I sort graph data?
You can filter graph data to show fewer transactions for a specific segment of the
performance test, and you can sort graph data to show the data in more relevant
ways. For example, you can filter the Average Transaction Response Time graph to
display only the check_itinerary transaction.

1. Click Average Transaction Response Time in the graph tree to open the
graph.

2. Select the graph and click the Set Filter/Group by button .

3. In the Transaction Name value box, select check_itinerary and click OK.
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The filtered graph displays only the check_itinerary transaction and hides all the
other transactions.

How can I publish my findings?
You can publish the findings from your analysis session in an HTML or Microsoft
Word report. The HTML report can be opened and viewed in any browser. The
Word report is more comprehensive than the HTML report, enabling you to include
general information about the performance test and to format the report to include
your company's name, logo, and the author's details.

For details about analyzing performance test results, refer to the LoadRunner
Analysis User Guide.

Viewing Performance Improvements and
Regressions
A trend report is a LoadRunner Enterprise feature that allows you to view changes
in performance from one performance test to another, or across several
performance tests. By analyzing these changes, you can easily identify
improvements or regressions in the measurement's performance.

For example, if you would like to analyze the performance trend of the average
transaction response time measurement of Transaction X, then the trend report
would display the changes in the response time from one test to the next, clearly
indicating whether this measurement improved (where the response time
decreased) or regressed (where it increased).

What steps are involved in working with trend
reports?
The process of creating and viewing a trend report involves the following steps:

l Step 1 - Creating the trend report. Creating the basic trend report by defining
its name, description and selecting a template.
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l Step 2 - Adding test runs to the trend report. Extracting test run data from
Analysis to the trend report.

l Step 3 - Viewing trend report data. Opening the trend view and analyzing the
trending information.

Creating the Trend Report
You create the trend report from the main Trend Reports page.

To create the trend report:

1. Open the main Performance Trending page.

In the top banner, click the module name or the dropdown arrow and select
Reports > Performance Trending.

2. Define a new trend report.

On the Performance Trending page, click the Create Trend Report button.

Enter a name and description for the report and click Create.

3. Add performance test run data to the report.

a. Click Add Runs and select a project and test set. All analyzed instances of
the performance test appear in the grid.

b. Select the analyzed instances of the test that you want to add to the trend
report.

Note: To add test runs to the trend report, there must be a data
processor in your project's host pool. For details, contact the
administrator.

c. By default, data collected from the whole test run is available for trending.
To make only part of the test run available for trending, click Time Range,
and select Trend Part of Run.

Select the part of the run to trend by entering the start and end times in the
Start Time and End Time boxes, and click OK.

To revert back to the default setting, select Trend complete run.
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d. Click Add or Add & Close. LoadRunner Enterprise uploads the test runs from
Analysis and adds them to the trend report. The trend report opens
displaying the Trend Overview tab.

Viewing Trend Report Data
In the following section, we will look at trending information for the average
transaction response time measurement only.

To view trending information:

On the trend report, click the Performance tab.

In the trend view that opens, you see a table that displays the transactions that
were present in the test run, as well as the average transaction response times for
each selected instance of the test run.

By comparing these average transaction response time figures, you can identify if
the performance of the transaction improved or regressed from one test run to the
next.

The following example illustrates this point.

Transaction Response Time (Compare to baseline)

Name Type

Average

run 3 [Base] run 4 run 5 run 6

All TRT 4.567 1.22 (-73.29%) 2.32 (-49.2%) 12.455 (+172.72%)

TRX_01 TRT 2.045 4.073 (+99.17%) 2.035 (-0.49%) 1.05 (-48.66%)

TRX_02 TRT 1.045 2.07 (+98.09%) 1.015 (-2.87%) 1.051 (+0.57%)

TRX_03 TRT 3.053 3.067 (+0.46%) 2.009 (-34.2%) 2.654 (-13.07%)

TRX_04 TRT 6.055 6.868 (+13.43%) 5.011 (-17.24%) 7.05 (+16.43%)

In the trend view shown above, four transactions (TRX_01, TRX_02, TRX_03, and
TRX_04) are displayed and their average Transaction Response Time
measurement is being trended from four performance test runs: 3, 4, 5, and 6.
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Test run 3 has been automatically defined as the baseline run, (as indicated by the
word Base in brackets). This means that the average transaction response times
contained in the other tests are compared to test run 3 only.

In test run 3, the average transaction response time for TRX_01was 2.045. The
average transaction response time for the same transaction in test run 4was
4.073, which represents a slower response time and therefore a regression in the
performance of this measurement. The percentage difference between the two
figures is displayed in parenthesis, in this case +99.17%.

In test run 6, the average transaction response time for TRX_01was 1.05, which
represents a faster response time that test run 3, and therefore a performance
improvement. The percentage difference between the two figures is displayed in
parenthesis, in this case -48.66%.
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