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Welcome
Welcome to the OpenText™Enterprise Performance Engineering Quick Start.

OpenText Enterprise Performance Engineering is a Web-enabled global

performance testing tool, designed to streamline the testing process and increase

the test eff iciency for mult iple concurrent performance tests across mult iple

geographic locations.

This Quick Start is a self-paced guide designed to lead you through the process of

creating, running, and analyzing a performance test, and to introduce you to the

testing environment.

Note: This guide assumes that your environment has been fully installed and
configured, and that a domain and project have been set up. For details,
contact your OpenText Enterprise Performance Engineering administrator.

Quick Start lessons
The Quick Start contains the following lessons:

Lesson Description

"Overview" on
page 7

Provides an overview of OpenText Enterprise
Performance Engineering and the performance testing
applications.

"Creating Vuser
scripts" on page 9

Describes the steps involved in recording Vuser scripts
using OpenText Virtual User Generator.

"Creating and
designing
performance tests"
on page 15

Describes the steps involved in creating and designing
performance tests.

"Running
performance tests"
on page 23

Describes the steps that are necessary before running a
performance test, and how to begin a test run.
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Lesson Description

"Post- run analysis
and trending" on
page 29

Describes how to analyze test run data using Analysis,
and how to view performance improvements and
regressions using the Trend Reports feature.
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Overview
This lesson provides a brief overview of the Performance testing application, and

of the applications that are involved in the testing process.

Notes:

l The Quick Start describes how to run a performance test with a single host
functioning as both a Controller and a load generator (C+LG). However,
due to possible heavy load on the Controller and load generator hosts
during a performance test, it is best practice to assign these functions to
separate host machines.

l Ensure that the latest standalone versions of OpenText Virtual User
Generator (VuGen) and Analysis are installed on your system.

In this lesson you will learn about:

l " Performance testing process" below

l "Performance testing applications" on the next page

Performance test ing process
Using OpenText Enterprise Performance Engineering, you create performance

tests in which you define the events that occur during a testing session. During a

test, human users are replaced at physical machines with virtual users, or Vusers.

These Vusers create load on your system by emulating actions of typical users in a

repeatable and predictable manner.

What is the test ing process?

The testing process consists of the following basic processes:

l Creating the script. Capturing typical end-user business processes performed

on your application.

l Designing the performance test. Setting up the test environment by defining

events that occur during the testing session.
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l Preparing to run the performance test. Adding the performance test to a test

set and reserving a timeslot for the test.

l Running the performance test. Driving, managing, and monitoring the test.

l Analyzing the results and viewing performance trends. Analyzing the

performance data generated during the test run, and viewing trending

information which identif ies performance improvements and regressions over

time.

These processes are explained in more detail in the lessons that follow.

Performance test ing applicat ions
Each step in the testing process is carried out by one of the performance testing

tool components. The components are as follows.

Application Description

OpenText
Virtual User
Generator
(VuGen)

Creates the script and generates virtual users, or Vusers.
VuGen does this by capturing actions that typical end-users
would perform on your application, and then records these
actions into automated Vuser scripts. These Vuser scripts form
the foundation of a performance test.

OpenText
Enterprise
Performance
Engineering

Provides the central console from which you build, manage, and
monitor a test.

Analysis Analyzes the performance test and provides graphs and reports
with in-depth performance analysis information. Using these
graphs and reports, you can pinpoint and identify the
bott lenecks in your application and determine what changes
need to be made to your system to improve its performance.

Next steps:
l "Creating Vuser scripts" on the next page

Quick Start Guide

Overview

OpenText Enterprise Performance Engineering (26.1) Page 8 of 38



Creating Vuser scripts
This lesson explains the steps involved in recording Vuser scripts using OpenText

Virtual User Generator.

This section includes:

l "Recording Vuser scripts" below

l "How do I start recording user activity?" below

l "How do I record a script?" on the next page

l "How do I view my script?" on page 11

l "How do I save the script?" on page 14

Recording Vuser scripts
You record Vuser scripts using OpenText Virtual User Generator (VuGen). A Vuser

script is a record of a typical end-user business process. VuGen works on a

record-and-playback principle.

As you walk through a business process on your application, VuGen records your

actions into an automated script which later forms the foundation of the

performance test.

How do I start recording user act ivity?
You begin by opening Vugen and creating a blank script.

1. Start VuGen.

Double-click the Virtual User Generator shortcut icon on your desktop.

The VuGen Start Page opens.

2. Create a blank Web script.

a. In the toolbar above the VuGen Start Page, click the Add New Script button

. The Create a New Script dialog box opens.
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A protocol is the language that your client uses to communicate with the

back end of the system.

b. Make sure the Category type is Single Protocol. VuGen displays a list of the

protocols that are available for a single-protocol script.

c. From the list of available protocols, select a protocol (example: for a Web-

based application, select Web - HTTP/HTML) and click Create. VuGen

creates a blank Vuser script and displays the script in the VuGen Editor.

How do I record a script?
The next stage in creating user emulation is recording the events performed by a

real user. In the previous section, you created an empty script. In this section, you

will record a script.

Note: The following exercise explains how to record a scripts for a Web-
based application (Web - HTTP/HTML).

1. Start recording.

a. Click the Record button on the VuGen toolbar. The Start Recording

dialog box opens.

b. In the Record into action box, select Action.
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c. In Record, select Web Browser.

d. In the URL address box, enter the URL address on the Web application

under test.

e. Keep all other default sett ings.

f. Click Start Recording. A new web browser opens and displays the Web

application under test.

The floating Recording toolbar opens.

2. Record your script.

Navigate through your Web application.

3. Stop recording.

Click the Stop Recording button on the floating toolbar to stop the

recording process.

VuGen generates the required code and inserts the code into the Vuser script.

How do I view my script?
VuGen recorded your steps from the moment you clicked the Start Recording

button to the moment you clicked the Stop Recording button. You can now use

VuGen to view the script.

1. Display the Solution Explorer tab.

Make sure the Solution Explorer tab is selected.
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This tab provides you structured access to the different parts of a Vuser script,

as well as to a number of files that are associated with the Vuser script.

2. Display the Step Navigator tab.

Click the Step Navigator tab.
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The Step Navigator displays an icon-based view of the script that lists the

actions of the Vuser as steps. For each action you performed during recording,

VuGen generated a corresponding step in the Step Navigator.

The Step Navigator displays a snapshot icon to indicate that a specif ic step

contains a snapshot.

3. View a step in the VuGen Editor.

Make sure Tools > Options > Editor> General > Show Class\Function

Browser is selected in the VuGen Editor.

Double-click any step in the Step Navigator to display the corresponding

function in the VuGen Editor. The Editor displays a text-based view of the

script.
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In the Editor, the actions of the Vuser are listed as API functions. VuGen uses

color-coding to show the functions and their argument values in the script. You

can enter C or API functions, as well as control f low statements, directly into

the script.

How do I save the script?
Select File > SaveScript As and save the script locally on your desktop. For

example, enter Scripts. The script f ile should be zipped. After you have created

your performance test, you will upload the script to OpenText Enterprise

Performance Engineering.

Next steps:
l "Creating and designing performance tests" on the next page
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Creating and designing performance
tests
This lesson explains how to manage test assets in OpenText Enterprise

Performance Engineering, and the steps involved in creating and designing a

performance test.

In this lesson you will learn about:

l "Signing in" below

l "Adding Vuser scripts" on the next page

l "Monitoring performance tests" on page 17

l "Creating performance tests" on page 19

l "Designing performance tests" on page 19

Signing in
You sign in to OpenText Enterprise Performance Engineering as follows.

1. Open your web browser and enter the server URL in the format:

http://<Server name>/loadtest.

Note: If more than one server is installed in your system together with a
load balancer, access the machine by entering the load balancer's URL.
Alternatively, you can also enter the server's defined internal URL.

2. The Sign in window opens.

If OpenText Enterprise Performance Engineering was configured for external

authentication (SSO), the Login and Password f ields do not appear in this

window and you should be redirected to your identity provider’s login screen.

3. In the Sign in page, enter your user name and password assigned to you by

your site administrator.
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4. Click the Authenticate button. Your user name and password are verif ied and

domains and projects you can access are shown.

5. In the Domain and Project window, select a domain and project. By default, the

last domain and project in which you were working are displayed.

6. Click Sign in. The Performance testing application opens.

Next steps:
l "Adding Vuser scripts" below

Adding Vuser scripts
The first step in your test design process is to add your Vuser script to OpenText

Enterprise Performance Engineering. Adding the script involves two steps:

Creating a scripts folder, and uploading the script to the folder.

How do I upload the Vuser Script?

You upload the script from within OpenText Enterprise Performance Engineering,

as follows.

1. Make sure the script is saved locally and is zipped.

2. Click the Navigation menu and select Test Management > Tests &

Scripts.

3. Create a script folder.

a. Select Subject.

b. Click the New Folder button , and specify a name for the folder, for

example, Scripts.

c. Click OK to add the folder.

4. On the module toolbar, click the Upload Script button . The Upload Scripts

dialog box opens.

5. In the Select Folder box, select the scripts folder you created above.
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6. Click the Select button and go to the location of the zipped script f ile.

7. Click Upload to upload the script.

Next steps:
l "Monitoring performance tests" below

Monitoring performance tests
This lesson explains how to use online monitors to monitor performance test runs.

Monitoring overview
You monitor performance test runs using the OpenText Enterprise Performance

Engineering online monitors. For example, you use the System Resource monitors

to monitor a machine's system resource usage during a performance test and

identify server performance bott lenecks.

A primary factor in a transaction's response time is its system resource usage.

Using the resource monitors, you can monitor the Windows Resource usage on a

machine during a test run, and determine why a bott leneck occurred on a specif ic

machine.

What is a monitor prof ile?
To monitor server resources during the test, you select the type of monitors to run

and the servers whose resources you want to monitor. You then add the

measurements to monitor for each server. These monitor sett ings can be saved as

a monitor profile which can be used by any performance test in your project.

The following section shows you how to create a monitor profile and how to add a

Windows Resource Monitor to it.
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How do I create a monitor prof ile?
You create and configure a monitor profile as follows:

1. Click the Navigation menu and select Assets > Monitors.

2. Create a folder for the monitor profile.

3. Select the folder, and click the New Monitor Profile button . The New

Monitor Profile dialog box opens, enabling you to add a new monitor profile.

4. Select Monitor Profile, and enter the required information and click OK to add

the monitor profile to the folder.

5. In the Monitor Profile page, click the New Monitor button . In the Add New

Monitor page that opens, you can select the monitors that you want to run.

6. Select the Windows Resources monitor type and click Next.

7. Enter the server details and then click Get Counters to display a list of

available metrics and counters.

8. Select the measurements that you want to monitor, and then click the Add

button to add the counters to the Selected Counters table.

9. Click Save. The monitor is added to your monitor profile.

You add the monitor profile to the test as part of the test design process.

Next steps:
l "Creating performance tests" on the next page
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Creating performance tests
To create a test, you begin by creating a test folder, and then creating the test and

adding it to the folder. In the next section, you will learn how to design the test in

the Test Designer.

How do I create a performance test?

You create the test as follows:

1. Click the Navigation menu and select Test Management > Tests &

Scripts.

2. In the test management tree, select the Subject root folder, click the New

Folder button . Enter a folder name and click OK.

3. Select the folder from the tree.

4. Click the New Test button . Enter the fields in the Create New Performance

Test dialog box.

Next steps:
l "Designing performance tests" below

Designing performance tests
You design your performance test in the Performance Test Designer.

How do I open the Performance Test Designer?
You open the test designer as follows:

1. Click the Navigation menu and select Test Management > Tests &

Scripts.

2. Select the test you created above, and click the Edit Test button on the

toolbar. The Performance Test Designer opens.
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How do I design the performance test?
From the Groups and Workload view in the Performance Test Designer, you

perform the basic test design steps. You design the test as follows:

1. Assign a Controller to the test.

a. Click the dropdown arrow adjacent to the Controller box (in the Summary

pane). The Select Controller dialog box opens.

b. Select Specific.

c. Select from the list the host machine that has been assigned the Controller

and Load Generator (C+LG) purpose.

2. Add Vuser scripts.

a. In the Groups pane, click the Add Group button . The Add Group dialog

box opens, displaying the Scripts tree with the script that you uploaded

previously.

b. Select the script and click Add to add it to the test. The script appears in the

Groups pane.

3. Add load generators.

a. From the Groups pane toolbar, click Assign LGs.

The Assign Groups to Load Generators dialog box opens.
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b. In the Groups column, select the Vuser groups to use in the test.

c. In the Load Generators column, select the Specific tab, and from the list

that appears, select the host machine that has been assigned the Controller

and load generator (C+LG) purpose.

d. Click Apply Assignment.

4. Configure the schedule settings.

A schedule defines the actions of the Vusers for the performance test run, for

example the behavior of 10 Vusers emulating 10 users simultaneously logging

on to the same Web site.

Because typical users do not perform the same action simultaneously, the

Scheduler allows you to schedule a performance test according to a more

realist ic portrayal of typical user behavior.

Define the schedule as follows:

In the Scheduler pane of the Groups and Workload tab, click in each of the

schedule actions in the Actions grid and define them as follows:

l Initialize.

l Start Vusers.

l Duration.

l Stop Vusers.
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The schedule graph displays a graphical representation of the defined

schedule. The lines in the graph correspond to the actions defined in the

Actions grid.

How do I add the monitor prof ile to the test?
You add the monitor profile to the test as follows:

1. Click the Navigation menu and select Test Management > Tests &

Scripts.

2. In the test management tree, select the test that you created in "Creating

performance tests" on page 19 and click Edit Test.

3. In the Performance Test Designer window, click the Assets tab and select

Monitors.

4. Click the Assign Monitors button . From the Monitor tree, select the monitor

profile and click Select & Close to add it to the test.

Next steps:
l "Running performance tests" on the next page
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Running performance tests
This lesson explains the steps that are necessary before you run the performance

test, and how to begin a test run.

l "Creating test sets" below

l "Reserving Timeslots" on the next page

l "Running performance tests" on page 26

Creating test sets
The next step in the performance testing process is the creation of a performance

test set.

What is a test set?
After you design the performance test in the Testing module, you organize the test

run by creating a test set, and adding an instance of the test to the test set. The

purpose of a test set is to enable you to group together tests that were created for

similar goals.

How do I create a test set?
You create the test set and add the test to it as follows:

1. Create the test set.

a. In the Performance Test Designer, click Save and Run. The Manage Test

Sets dialog box opens.

Tip: You can also create or assign a test set from the Create New
Performance Test dialog box. For details, see "Creating performance
tests" on page 19.

b. Click the Root test set folder, and click the New Folder button . Specify a

name for the Test Set folder, for example, Test_set_folder.
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2. Assign the performance test to the test set.

a. Select the folder you created above, and click the New Test Set button .

b. Enter the test set name, for example, My_Test_Set. Click Assign. Your test is

assigned to the test set.

Next steps:
l "Reserving Timeslots" below

Reserving Timeslots
Before you run the test, you reserve a timeslot to ensure that the resources

needed are available for the duration of the test.

How do I reserve a timeslot?

1. Click the Navigation menu and select Timeslots.

2. From the calendar or grid view, click the New/Add Timeslot button . The

Add New Timeslot dialog box opens.

3. Define the following information:

l Start. Choose Manually as the method for running tests. The timeslot

reservation reserves testing resources only.

l Name. Enter a name for the timeslot.

l Test/Test Instance. Select the test you created and the test set instance to

link to the timeslot. The number of Vusers and hosts that were defined as part

of the test design process are automatically displayed.

l Duration. Set the start t ime, and enter a duration for the test.
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l Post Run Action. If the administrator did not set an action across the project

(the options are available for selection), select Collate and Analyze.

4. Click Calculate Availability. The availability of the requested resources during

the selected timeslot is calculated. The results of this calculation are displayed

in the Timeslot Status tab and graphically on the time chart.

Note: If the timeslot cannot be reserved, reselect your resources or
adjust the start t ime, taking into account the reasons displayed in the
Timeslot Status tab.

5. When you find a valid timeslot, click Add to save the timeslot.

Next steps:
l "Running performance tests" on the next page
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Running performance tests
Now that you have designed the performance test, added an instance of the test

to a test set, and reserved a timeslot for the test, you are ready to run the test and

observe how your application performs under load.

How do I run the performance test?
You run the performance test as follows:

1. Click the Navigation menu and select Test Management > Tests &

Scripts.

2. Select your test in the test management tree.

3. Click the Run Test button. The Run Performance Test dialog box opens.

4. Click the Reserved Timeslot tab.

5. Select the timeslot you reserved, and click Run.

The Init ializing Run page displays the performance test init ialization steps, and

the status for each step. If each step is completed successfully, the

performance test starts running and the Run Dashboard opens. The Test Run

page enables you to manage and monitor the test as it runs.

What does the Run Dashboard display?
The Run Dashboard is the control center from which the test run is managed and

monitored.
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The Run Dashboard displays the following.

Pane/Tab Description

Summary The Summary pane displays a synopsis of the running performance
test.

Test run
views

The Test Run Details area provides four views:

l Graphs: This is the view displayed in the above image. This view
displays performance measurements for those resources being
monitored in the test. This enables you to monitor how the
application under test is performing in real t ime and identify
where potential bott lenecks exist.

l Groups: The Groups view displays the statuses of the Vusers in
each Vuser group in the performance test.

l Transactions: The Transactions view displays how many
transactions have been run successfully or unsuccessfully.

l Messages: The Messages view displays error, warning, debug,
and output messages that are sent to the Controller by the
Vusers and load generators during a test run.

l Monitors. The Monitors view displays monitors from all the
monitor profiles and over firewall agents that are associated with
the selected test. You can add new monitors to the test from this
view.
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Pane/Tab Description

Tabs In the Graphs pane, click the More button and select Graphs. A list
of the configured online graphs is displayed. You can select which
graphs to display in the Graphs view.

Next steps:
l "Post- run analysis and trending" on the next page
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Post- run analysis and trending
This lesson explains how to analyze test run data using Analysis, and how to view

performance improvements and regressions using the Trend Report feature.

In this lesson you will learn about:

l "Analyzing performance test tun results" below

l "Viewing performance improvements and regressions" on page 34

Analyzing performance test tun results
Now that you have completed running the performance test, you can use

Analysisto analyze the performance data generated during the test run. Analysis

gathers the performance data into detailed graphs and reports. Using these

graphs and reports, you can pinpoint and identify the bott lenecks in the

application, and determine what changes need to be made to the system to

improve its performance.

How do I view Analysis information?
To view Analysis data for your actual performance test, you perform the following

steps:

1. Install Analysis

You can download Standalone Analysis from the Click the Navigation menu

and select Download Applications > Standalone Analysis.

2. Collate and analyze the results for the test run.

a. Click the Navigation menu and select Test Runs. Select the

performance test you just ran in the test management tree, and click the

Runs tab.

b. If the test run is in the Before Collating Results state, right-click the run,

and select Collate. The results for the test run are collated.
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c. When result collation has finished, and the test run is in the Before Creating

Analysis Data state, right-click the run, and select Analyze.

d. When OpenText Enterprise Performance Engineering has finished analyzing

the results, download the Results_<#>.zip f ile for the test run.

3. Open the Analysis session file for your performance test.

a. In Analysis, select File > Open. The Open Existing Analysis Session dialog

box opens.

b. Click File System, and go to the Results_<run_id>.zip f ile for the instance

of your performance test that you want to analyze.

c. Double-click the Results_<run_id>.zip f ile. The Analysis session file is

opened in Analysis.

For information about how to work within Analysis, see the OpenText

Professional Performance Engineering Help Center.

Did I reach my goals?
Analysis opens displaying the Summary Report. The Summary Report provides

general information about the performance test run. In the Statistics Summary of

the report, you can see how many Vusers ran in the test and view other statist ics

such as the total/average throughput, and the total/average hits. The Transaction

Summary of the report lists a summary of the behavior of each transaction.

How can I view the graphs?
The graph tree in the Analysis window shows the graphs that are open for viewing.

From the graph tree, you can choose to open new graphs and remove graphs that

you no longer want to view. The graphs are displayed in the graph viewing area of

the Analysis window. You can view data from the selected graphs in the graph

legend.

As an example, let 's analyze the Average Transaction Response Time graph. Using

this graph, you can view the behavior of the problematic transactions during each
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second of the performance test run. In this section, you view the behavior of the

check_itinerary transaction.

To open and analyze the Average Transact ion Response Time
graph:

1. Select Graph > Add New Graph. The Open a New Graph dialog box opens.

2. Under Transactions, select Average Transaction Response Time.

3. Click Open Graph. The Average Transaction Response Time graph opens in

the graph viewing area.

Click Close to exit the Open a New Graph dialog box.
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4. In the legend, click check_itinerary. The check_it inerary transaction is

highlighted in the graph and in the legend below the graph.

Notice how the average response time of the check_itinerary transaction

fluctuates greatly compared to the other transactions at the bottom of the

graph, which follow a more or less stable average response time.

How can I compare data from different graphs?
You can join two graphs together to see the effect of one graph's data on another

graph's data. This is called correlating two graphs. For example, you can correlate

the Running Vusers graph with the Average Transaction Response Time graph to

see the effect of a large number of Vusers on the average response time of the

transactions.

1. Choose Graph > Add New Graph. The Open a New Graph dialog box opens.

2. Under Vusers, select Running Vusers.

3. Click Open Graph. The Running Vusers graph opens in the graph viewing area.

Click Close to exit the Open a New Graph dialog box.

4. Select the Running Vusers graph and click the Merge Graphs button on

the main toolbar.

5. From the Select graph to merge with list, select Average Transaction

Response Time.

6. In the Select type of merge area, select Correlate, and click OK.

The Running Vusers and Average Transaction Response Time graphs are now

represented by one graph which opens in the graph viewing area.

Quick Start Guide

Post- run analysis and trending

OpenText Enterprise Performance Engineering (26.1) Page 32 of 38



Another Analysis tool, Auto Correlate (click ), merges all graphs containing

data that could have had an effect on a transaction. Correlations of the transaction

with each element are displayed, allowing you to deduce which elements had the

greatest effect on the transaction.

How can I sort graph data?
You can filter graph data to show fewer transactions for a specif ic segment of the

performance test, and you can sort graph data to show the data in more relevant

ways. For example, you can filter the Average Transaction Response Time graph to

display only the check_itinerary transaction.

1. Click Average Transaction Response Time in the graph tree to open the

graph.

2. Select the graph and click the Set Filter/Group by button .

3. In the Transaction Name value box, select check_itinerary and click OK.
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The filtered graph displays only the check_itinerary transaction and hides all the

other transactions.

How can I publish my findings?
You can publish the findings from your analysis session in an HTML or Microsoft

Word report. The HTML report can be opened and viewed in any browser. The

Word report is more comprehensive than the HTML report, enabling you to include

general information about the performance test and to format the report to include

your company's name, logo, and the author's details.

For details about analyzing performance test results, see the Analysis section in

the OpenText Professional Performance Engineering Help Center.

Next steps:
l "Viewing performance improvements and regressions" below

Viewing performance improvements and
regressions
This lesson explains how to view changes in performance from one performance

test to another using a trend report.

Trend reports
A trend report is a feature that enables you to view changes in performance from

one performance test to another, or across several performance tests. By

analyzing these changes, you can easily identify improvements or regressions in

the measurement's performance.

For example, if you would like to analyze the performance trend of the average

transaction response time measurement of Transaction X, then the trend report

would display the changes in the response time from one test to the next, clearly

indicating whether this measurement improved (where the response time

decreased) or regressed (where it increased).
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What steps are involved in working with trend
reports?
The process of creating and viewing a trend report involves the following steps:

l Step 1 - Creating the trend report. Creating the basic trend report by defining

its name, description and selecting a template.

l Step 2 - Adding test runs to the trend report. Extracting test run data from

Analysis to the trend report.

l Step 3 - Viewing trend report data. Opening the trend view and analyzing the

trending information.

Creating the Trend Report
You create the trend report from the main Trend Reports page.

To create the trend report:

1. Open the main Performance Trending page.

Click the Navigation menu and select Reports > Performance Trending.

2. Define a new trend report.

On the Performance Trending page, click the Create Trend Report button .

Enter a name and description for the report and click Create.

3. Add performance test run data to the report.

a. Click Add Runs and select a project and test set. All analyzed instances of

the performance test appear in the grid.

b. Select the analyzed instances of the test that you want to add to the trend

report.

Note: To add test runs to the trend report, there must be a data
processor in your project 's host pool. For details, contact the
administrator.

Quick Start Guide

Post- run analysis and trending

OpenText Enterprise Performance Engineering (26.1) Page 35 of 38



c. By default, data collected from the whole test run is available for trending.

To make only part of the test run available for trending, click Time Range,

and select Trend Part of Run.

Select the part of the run to trend by entering the start and end times in the

Start Time and End Time boxes, and click OK.

To revert back to the default sett ing, select Trend complete run.

d. Click Add or Add & Close. The test runs are uploaded from Analysis and

added to the trend report. The trend report opens displaying the Trend

Overview tab.

Viewing Trend Report data
In the following section, we will look at trending information for the average

transaction response time measurement only.

To view trending information:

On the trend report, click the Performance tab.

In the trend view that opens, you see a table that displays the transactions that

were present in the test run, as well as the average transaction response times for

each selected instance of the test run.

By comparing these average transaction response time figures, you can identify if

the performance of the transaction improved or regressed from one test run to the

next.

The following example illustrates this point.

Transaction Response Time (Compare to baseline)

Name Type

Average

run 3 [Base] run 4 run 5 run 6

All TRT 4.567 1.22 (-73.29%) 2.32 (-49.2%) 12.455 (+172.72%)

TRX_01 TRT 2.045 4.073 (+99.17%) 2.035 (-0.49%) 1.05 (-48.66%)

TRX_02 TRT 1.045 2.07 (+98.09%) 1.015 (-2.87%) 1.051 (+0.57%)
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Name Type

Average

run 3 [Base] run 4 run 5 run 6

TRX_03 TRT 3.053 3.067 (+0.46%) 2.009 (-34.2%) 2.654 (-13.07%)

TRX_04 TRT 6.055 6.868 (+13.43%) 5.011 (-17.24%) 7.05 (+16.43%)

In the trend view shown above, four transactions (TRX_01, TRX_02, TRX_03 , and

TRX_04 ) are displayed and their average Transaction Response Time

measurement is being trended from four performance test runs: 3 , 4 , 5 , and 6 .

Test run 3 has been automatically defined as the baseline run, (as indicated by the

word Base in brackets). This means that the average transaction response times

contained in the other tests are compared to test run 3 only.

In test run 3 , the average transaction response time for TRX_01 was 2.045 . The

average transaction response time for the same transaction in test run 4 was

4.073 , which represents a slower response time and therefore a regression in the

performance of this measurement. The percentage difference between the two

figures is displayed in parenthesis, in this case +99.17%.

In test run 6 , the average transaction response time for TRX_01 was 1.05 , which

represents a faster response time that test run 3 , and therefore a performance

improvement. The percentage difference between the two figures is displayed in

parenthesis, in this case - 48.66%.
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