Integrations

This topic lists the supported software versions of the tools that ALM Octane integrates with.

For details on the following integrations, see ALM Octane integrations overview.

Caution: When working with integrations, configure ALM Octane with a secured TLS (SSL) connection. For instructions, see ALM Octane Secure Deployment and Configuration Guidelines.

Component Type CI Server Version Plugin Version
CI Servers Jenkins

2.138.4 and later

Latest verified: 2.263.1

6.1 and later
TeamCity

2019.1.x and later

Latest verified: 2020.2

1.3.7 and later
Bamboo

6.3.1 and later

Latest verified: 7.1

1.10.2 and later

Azure DevOps Server

Microsoft Team Foundation Server (TFS)

2015 update 4, 2017, 2018

1.4 and later

Azure DevOps Server

Azure DevOps Services - Pipelines

2019, 2020 Technical preview on Azure Marketplace
GoCD 20.8 and later 1.0.7 and later
GitLab

GitLab Enterprise Edition 12.6.3 and later

Latest verified: 13.4

1.1.63 and later

 

Component Type Version
Automated testing Various testing tools are supported.

For details on supported tools and versions, see Supported Integrations on the Application Automation Tools site.

Performance testing LoadRunner Enterprise

12.63

Project Portfolio Management Project and Portfolio Management (PPM)

9.63

Manual testing Sprinter 15.0.1
Micro Focus QoT (Quality of Things) 2.1 and later

IDE plugins

(Prerequisite: JavaFX is installed)

IntelliJ IDEA

2017.1 and later

On the following operating systems:

  • Windows

  • MacOS

  • Linux

Eclipse

2018-09 and later

On the following operating systems:

  • Windows

  • MacOS

Microsoft Visual Studio

2017 and 2019

All editions: Community, Professional, and Enterprise

OData N/A

4.0

Any tool that supports OData version 4.0 is likely to work well with ALM Octane.

ALM Octane OData support has been tested with Power BI and Excel.

For OData version 4.0 support, download and install the Microsoft Power Query for Excel add-in.  

Code coverage reports SonarQube 7.2 and later
Business Driven Development (BDD) Cucumber-jvm 4.2-4.8.1 and 1.2
JBehave 4.7 (Gherkin syntax only)

See also: