System requirements

This topic provides the details about the necessary system requirements.

Hardware

Component Type Value

Screen resolutions

Screen resolutions between the recommended and minimum values are also supported.

Recommended 1920 x 1080
Minimum supported 1024 x 768

Production environments: 

 

Contact customer support for the most up-to-date be benchmark documentation.

Recommended: 2 ALM Octane server machines, minimum

Minimum: 1 ALM Octane server machine

CPU: 4

RAM: 8 GB

Heap: Max 4 GB

Disk space: At least 500 GB (network storage recommended)

1 database server machine

CPU: 8

RAM: 16 GB

Recommended: 3 Elasticsearch server cluster machines

Minimum: 1 Elasticsearch server machine

CPU: 4 and higher

RAM: 8 GB

1 load balancing component (load balancer or reverse proxy) to enable cluster

Pre-production or test environments: 

(Recommended values)

Contact customer support for the most up-to-date be benchmark documentation.

1 ALM Octane server machine

CPU: 4

RAM: 8 GB

Heap: Max 4 GB

Disk space: 200 GB

1 database server machine

Can be an existing database server.

CPU: 8

RAM: 16 GB

1 Elasticsearch server machine

CPU: 4 and higher

RAM: 8 GB

Virtual machines

VMware or any virtual machine is supported, provided it has dedicated resources.

Back to top

Software

Component Type Version
Server operating system

CentOS

6.5 or later

We strongly recommend 7.x.

Suse

12 with SP1 or SP2

Red Hat Enterprise Linux (RHEL)

6.5 or later

We strongly recommend 7.2 and later.

Windows 2012, 2016

Browser

Chrome (recommended) 

Chrome: The two latest versions

Chrome for business

Firefox (recommended) 

Firefox: The two latest versions

ESR: 52

Internet Explorer

11

Note: CP 11 is the last version of ALM Octane that will support Internet Explorer. For details: SaaS or on-premises.

Apple Safari 10, 11
JDK  

Open/Oracle JDK 8

Java 8 only.

Make sure the latest security updates are installed on the ALM Octane server at all times.

Back to top

Database and Elasticsearch

Component Type Version
Database Oracle

19c, 18c, 12c

Standard or Enterprise edition, with character set AL32UTF8

SQL Server

2017, 2016, 2014

Standard or Enterprise edition, case-insensitive collations only.

Elasticsearch N/A

6.8.1

  • For details on installing Elasticsearch, see knowledge base article KM02494295.

  • For details on upgrading to a new Elasticsearch version, see knowledge base article KM03207448.

Back to top

Integrations

For details on the following integrations, see ALM Octane integrations overview.

Caution: When working with integrations, configure ALM Octane with a secured TLS (SSL) connection. For instructions, review knowledge base article KM02707977.

Component Type Version
CI Servers Jenkins 1.642.4 and later
TeamCity 9.1.6 and later
Bamboo

5.13 and later

Microsoft Team Foundation Server (TFS) 2018, 2017, 2015
GoCD 17.9 or later
GitLab GitLab Enterprise Edition 11.6.3-ee
Automated testing Various testing tools are supported.

For details on supported tools and versions, see Supported Integrations on the Application Automation Tools site.

Performance testing Performance Center

12.55

Manual testing Sprinter 14.03

IDE plugins

(Prerequisite: JavaFX is installed)

IntelliJ IDEA

2017.1 and later

On the following operating systems:

  • Windows

  • MacOS

  • Linux

Eclipse

Mars, Neon, Oxygen (2017), Photon (2018), 2018-09, 2018-12, 2019-03

On the following operating systems:

  • Windows

  • MacOS

Microsoft Visual Studio

2017 and 2019

All editions: Community, Professional, and Enterprise

OData N/A

2.0 and 4.0

Any tool that supports OData version 2.0 or 4.0 is likely to work well with ALM Octane.

ALM Octane OData support has been tested with Power BI and Excel.

For OData version 4.0 support, download and install the Microsoft Power Query for Excel add-in.  

Code coverage reports SonarQube 7.2

Back to top

Installation, setup, and synchronization

Component Version
Cloud environments

Amazon Web Services (AWS) 

Microsoft Azure

LDAP Server Active Directory, or any LDAP provider supporting the LDAP3 protocol
Synchronizer

Red Hat Enterprise Linux (RHEL) 6.5 and later

CentOS 6.5 and later

Micro Focus Connect

4.0 and later.

For details see Connect Help Center.

Jira synchronization

Jira 7.2.8 and later

Jira Cloud

ALM/Quality Center synchronization ALM 15.01, ALM/Quality Center 15.00 (non-SSO mode), 14.02 patch 2 and later, 12.60 patch 1, 12.55, 12.53, 12.50, 12.21, 12.01 patch 1 and later
ALM/Quality Center license sharing

ALM 12.60, 12.55, 12.53 (all patch levels), 12.21 patch 6

Quality Center 12.60, 12.55 patch 1, 12.53 (all patch levels), 12.21 patch 6

Note that 12.53 versions require a hotfix.

Back to top