Troubleshooting Topology – SiteScope Integration

This section provides information for troubleshooting issues related to the Topology – SiteScope integration.

Configure Monitors dialog box displays empty content or an error message

Problem Description

When clicking the Configure Monitors button, the dialog box opens with empty content, displaying either a red ‘x’ in the upper left corner, or an error message.

Troubleshooting

If the window displays empty content:

Possible Cause Action

The problem may be related to the SiteScope user interface integration. To check this:

Open SiteScope directly (that is, not through the topology integration) using the following URL: http://<SiteScope server>:8080/SiteScope.

If the SiteScope window fails to open correctly, perform the following steps:

  1. Ensure that Java (version 1.6 and above) is installed on the client machine.

  2. Open the Java Control Panel, and in the General tab, click Network Settings.

  3. Select Direct Connection.

If the SiteScope window opens correctly, and the problem persists when you open the SiteScope window from within the topology, verify that SiteScope is configured correctly for the topology integration as follows:
  1. Verify that the SiteScope Administrator account has a defined username and password.

  2. In SiteScope General Settings, verify that the Communication Security Passphrase from LW SSO Setting matches the one defined in ALM and Performance Center.

If you receive an error message, check the table below for an explanation or resolution.

Error Message Explanation/Resolution
SiteScope authentication failed due to invalid passphrase. Verify that the Communication Security Passphrase defined on the ALM Platform and the SiteScope server match. In SiteScope General Settings, verify that the Communication Security Passphrase from LW SSO Setting matches the one defined in ALM and Performance Center.
You have reached SiteScope points limit (500). To obtain additional points for free, contact Micro Focus support via your administrator. Performance Center customers are entitled to free additional points. To request the points, contact Micro Focus Software Support.
Trying to connect to an unsupported SiteScope version - this feature requires SiteScope 11.01 and above. Please contact your administrator. Contact your administrator to ensure that the correct version is installed.
Could not connect to SiteScope at the given URL: <SiteScope URL>. Error: <network error message> The SiteScope server name, port, or SSL was not entered correctly, the SiteScope service is down, or the SiteScope server is not accessible from the client machine over the network. Check if the included network error message provides an indication of the actual problem.
SiteScope internal error. Please contact your administrator. The exact SiteScope exception can be found in the ALM client log file. Contact Micro Focus Software Support for further assistance.

Back to top

Template deployment fails

Problem Description

An error message appears in the Fail Reason column of the Deploy Template Results dialog box.

Troubleshooting

Back to top

Topology graphs do not appear during runtime

Problem Description

The topology graphs do not appear in the Topology tab of the Performance Test Run page.

Troubleshooting

  • Check that the topology contains nodes with configured monitors, and that it is associated to the performance test.

  • Open the SiteScope window (from: http://<SiteScope server>:8080/SiteScope), and locate the group that corresponds to the topology. Verify that the group exists, that it has monitors, and that it is enabled in SiteScope. If the group is disabled, check the Controller log for related errors.

Back to top

Topology graphs appear without data during runtime

Problem Description

The topology graphs appear in the Topology tab of the Performance Test Run page, but do not contain any data.

Troubleshooting

  • In the Topology Designer Window, click the Configure Monitors button. In the Configure Monitors dialog box, verify that SiteScope can connect to and monitor topology machines.

  • Open the SiteScope window (from: http://<SiteScope server>:8080/SiteScope), and locate the group that corresponds to the topology. Verify that the group exists, that it has monitors, and that it is enabled in SiteScope. If the group is disabled, check the Controller log for related errors.

Back to top

Use SiteScope (instead of SiteScope for Load Testing) with Performance Center

Problem Description

You have installed SiteScope instead of SiteScope for Load Testing, and want to use the SiteScope server for integrating with the Topology feature without reinstalling it.

Troubleshooting

SiteScope has a minimum monitor frequency of 15 seconds, which is usually too long for working with Performance Center.

On the SiteScope Server, add the following entries to the master.config file. Alternatively, you can add them in the Infrastructure Preferences page.

  • _monitorMinInterval=1

  • _topazPageSkipEmptyValues=true

  • _maxMonitorSkips=60

  • _shutdownOnSkips=

For details about accessing the master.config file and the Infrastructure Preferences page, see the SiteScope documentation in the Software Documentation Portal.

Note: The maxMonitorSkips=60 and shutdownOnSkips= properties may affect SiteScope monitors which are unrelated to performance testing.

Back to top