Troubleshooting monitors

This section provides information on troubleshooting monitors.

Unable to create a monitor

Problem Description

You are unable to create a specific monitor.

Troubleshooting

  1. Make sure that the user trying to access the machine to monitor exists on this machine and has proper privileges. Usually IUSR_METRO is the user attempting to monitor.

    For example, if you add the Windows Resources monitor, the user IUSR_METRO must exist on the machine to be monitored and must have proper access rights.

  2. Some monitors require certain clients to reside on the Utility Server and the Controller.

    For Oracle, the Oracle Client must be installed.

  3. Make sure the agent required for a particular monitor is running on the machine that you want to monitor.

  4. Some monitors require access to a particular URL, from both the Performance Center utility server and the Controller, for monitoring purposes.

    For Apache, this URL is: http://<server>:<port>/server-status:auto

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Monitor fails to retrieve measurements

Problem Description

This problem can occur with Windows Resource, Microsoft IIS, Microsoft SQL, or Microsoft ASP monitors when:

  • Configuring a monitor (when you click Get counters), or

  • During a test run (for example, if you have created a monitor profile and then change the Performance Center system user and run the test). An error is displayed in the Errors window and no data is displayed in the monitor's online graphs.

Cause:

The Performance Center Server sends messages to the monitored server using the SMB2 protocol. This protocol uses the supplied user credentials for the session initialization, but the monitored machine sends another authentication request to the client, and the client sends the credentials of the user who runs the process that initiated the connection—the Performance Center system user account (IUSR_METRO by default).

If that user account does not exist on the remote server, authentication fails and the user that is being used for authentication and metrics retrieval is the one whose user name and password are provided in the Performance Center user interface when creating the monitor (when entering the server name and credentials in the Monitor Profile configuration).

If the Performance Center system user account exists on the monitored server, but is not a local admin on the remote server (or does not have the required permissions), the initial authentication succeeds, but retrieving the metrics from the remote server fails because the credentials provided in Performance Center when creating the monitor are not being used.

Solution:

  • Remove the Performance Center system user from the monitored machine, or

  • Deny access of the Performance Center system user to the monitored machine from Local security policy > User rights assignment > Deny access to this computer from the network.

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Some monitors do not display data

Problem Description

This problem can occur with PDH monitors, which include Windows Resources, MS IIS, SQL Server, Citrix Server, and Microsoft ASP.

These monitor require a NET USE connection to retrieve measurement data. When you select measurements or counters to monitor, the MonitorClient.exe process on the Performance Center agent machine uses the logged in user’s NET USE to connect to the application under test (AUT).

However, during the performance test run, the Performance Center agent invokes the MonitorServer.exe process to retrieve data from the AUT using the local user, IUSR_METRO. This means there is no NET USE connection between the Monitor Over Firewall machine and the AUT during the test run, resulting in no measurement data being received on the PDH monitors.

Troubleshooting

Ensure that the magentservice.exe on the Monitor Over Firewall machine is installed with the same user that you used to log on when you selected measurements or counters to monitor.

Perform the following steps on the Monitor Over Firewall Machine:

  1. Stop the Performance Center Agent Service.

    1. Select Start > Run and type services.msc.

    2. In the services list, right-click Performance Center Agent Service and select Stop.

  2. Select Start > Run and type cmd. The Command window opens.

  3. Type the following and press Enter:

    cd <Performance Center Monitor over Firewall installation>\launch_service\bin

  4. Type the following and press Enter:

    magentservice –remove

  5. Type the following and press Enter:

    magentservice –install <Logged on user name> <Password>

  6. Restart the Performance Center Agent Service using the same procedure described in step 1.

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Disabling automatic host monitors

Problem Description

The host monitors feature automatically configures basic windows monitor data for all the machines involved in a performance test (except for OFW machines). This data (CPU, disk space, and memory) is available during a performance test run in the online graphs, or afterwards when collating and analyzing the results. This feature is convenient as it works with auto-matched load generators. However, in environments where the network ports are closed, this feature may cause a significant slowdown when starting a performance test run.

Troubleshooting

Starting from Performance Center 12.50, you can disable the host monitors. For more information, see knowledge base article KM01517448.

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See also: