Supported Upgrade Paths

To upgrade to PPM version 9.50-9.51, you must have PPM version 9.40 (with or without service packs) installed. If an earlier version is installed, you must first upgrade to version 9.40, and then upgrade to PPM version 9.50-9.51.

For information on how to upgrade to version 9.40, see the Upgrade Guide for version 9.40.

Note: We strongly recommend upgrading to the latest version of PPM Center. In general, each new PPM version includes important product improvements that are not provided in earlier versions.

Caution: If your organization still uses a Documentum-based document management system (either embedded Documentum Content Server software we supply or integration with stand-alone Documentum Content Server software using connector), make sure you migrate it to PPM Center Database DMS using the Administration Console tool DMS Configuration on PPM version 9.13 or later before you upgrade PPM Center to version 9.40.

For detailed instructions about how to migrate a Documentum-based DMS, see the Document Management Guide and Reference for PPM version 9.20.

Caution: If you deployed an ALM content bundle for integration purpose on PPM version 9.12 or earlier, and configured any integration solutions using the ALM entities provided, to avoid any potential data loss with your integration solutions, make sure you upgrade PPM to version 9.14, then proceed to upgrade to version 9.20, then 9.30, 9.40, and then finally to version 9.50.

Note that unless advised otherwise, we strongly recommend you keep using the old ALM content bundle. There is no need to deploy a new ALM content bundle, regardless of which version of PPM you upgraded to.

The following table describes supported upgrade paths in more details.

Versions in parenthesis can be skipped. For example, if you want to upgrade PPM to 9.30 from 8.00, you should first upgrade to 9.10, with or without upgrading to 8.0x, then upgrade to 9.20, with or without upgrading to 9.2x, and finally upgrade to 9.30.

Current PPM Center Version

Can be Upgraded to

7.5 SP3 or earlier

8.00 > (8.0x) > 9.10 > (9.1x) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

7.5 SP4, 7.5 SP5, 7.5 SP6

8.00 > (8.0x) > 9.10 > (9.1x) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

7.5 SP7

8.00 > (8.0x) > 9.10 > (9.1x) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

8.00

(8.0x) > 9.10 > (9.1x) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

8.00.01

(8.0x) > 9.10 > (9.1x) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

8.02

(8.0x) > 9.10 > (9.1x) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

8.03 1 (build 1189 and build 1208)

9.10 > (9.1x) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

8.04

9.10 > (9.1x) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

9.10

(9.11~9.14) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

9.11

(9.12~9.14) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

9.12

(9.13~9.14) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

9.13

(9.14) > 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

9.14 (build 1435 or build 1460)

9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50
9.14.0001~9.14.0004 2

9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50

9.14.0005~9.14.0006 2, 9.20 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50
9.14.0007~9.14.0009 2, 9.21 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50
9.14.0010 2 9.20 > (9.2x) > 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50
9.22 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50
9.22.0001~9.22.0003 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50
9.22.0004~9.22.0006 2 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50
9.22.0007 2 9.30 > (9.3x) > 9.40 > (9.4x) > 9.50
9.30 (9.31~9.32) > 9.40 > (9.4x) > 9.50
9.31 (9.32) > 9.40 > (9.4x) > 9.50
9.32 9.40 > (9.4x) > 9.50
9.40 (9.41~9.42) > 9.50
9.41 (9.42) > 9.50
9.42 9.50
  1. PPM 9.10 and 9.11 were released before 8.03 and 9.12. Versions 8.03 and 9.12 include improvements to core functionalities that are not supported on the older versions 9.10 and 9.11.

    If PPM is running at version 8.03, do not upgrade to and then run at version 9.10, 9.11, or 9.12. Instead, upgrade from version 8.03 to version 9.10 temporarily without running PPM Center, and then upgrade immediately to version 9.12 or later.

  1. Defect fixes included in patches (up until 9.14.0004) on top of version 9.14 are rolled into version 9.20. Version 9.21 contains defect fixes included in patches 9.14.0001 through 9.14.0006. Version 9.22 contains defect fixes included in patches 9.14.0001 through 9.14.0009. Version 9.22.0001 contains defect fixes included in patches 9.14.0001 through 9.14.0010. Version 9.22.0003 contains defect fixes since version 9.22. Version 9.32 contains defect fixes in patch 9.22.0004 through 9.22.0006.

    If PPM Center is running at patch 9.14.0005 or 9.14.0006, do not upgrade to and run at version 9.20. Instead, upgrade from 9.14.0005 or 9.14.0006 to 9.20 temporarily without running PPM Center, and then upgrade immediately to 9.21 or later.

    If PPM Center is running at patch 9.14.0007~9.14.0009, do not upgrade to and run at version 9.20. Instead, upgrade from 9.14.0007~9.14.0009 to 9.20 temporarily without running PPM Center, and then upgrade immediately to 9.22 or later.

    If PPM Center is running at patch 9.14.0010, do not upgrade to and run at version 9.20. Instead, upgrade from 9.14.0010 to 9.20 and then to 9.22 temporarily without running PPM Center, and then upgrade immediately to 9.22.0001 or later.

    If PPM Center is running at patch 9.22.0004~9.22.0006, do not upgrade to version 9.30 yet. Upgrade from 9.22.0004~9.22.0006 to 9.30 temporarily without running PPM Center, and then upgrade to 9.32 immediately.

    If PPM Center is running at patch 9.22.0007, do not upgrade to version 9.30 yet. Upgrade from 9.22.0007 to 9.30 temporarily without running PPM Center, and then upgrade to 9.40 immediately.