Selecting the Appropriate Integration Procedure

If multiple QC or ALM servers (instances) are integrated with PPM, some of the QC or ALM instances can be at QC 10.00 and others can be at ALM 11.x or later.

The procedure to configure integration of PPM with ALM is significantly different from the procedure to configure integration with QC 10.00. You must use only the appropriate procedure, as follows:

Caution: If you upgrade your PPM from an earlier version to 9.50,

  • And your QC instance is still at version 10.00, if you have no plan to upgrade your QC instance, you can continue to use existing integration of PPM requests and QC entities (defects or requirements) on that instance you have established previously.
  • And you upgrade your QC instance from version 10.00 to ALM version 11.x or later, existing integrations of PPM requests and QC entities (defects or requirements) on that instance are not upgraded. If the integrations are reestablished, they will operate as new integrations.

    They are shown as read-only entries on the Integration Configurations landing page (with an Upgrade icon available for each entry). You need to upgrade the exiting integration configurations one by one so that they will continue to work properly with all the existing data.

    Micro Focus does NOT recommend you re-establish the integrations after you have upgraded both PPM Server and QC server to the latest versions. If you re-establish the integrations, they will operate as new integrations. You risk corrupting the existing data or data loss on both servers.