Platform and Browser Requirements

Note: These are minimum requirements. Additional performance enhancing options, such as additional RAM/memory, may be desired.

Client requirements include the following:

  • Operating system

    • Microsoft® Windows® 7 Enterprise Edition (both 32- and 64-bit)

    • Microsoft® Windows® 8 Enterprise Edition (both 32- and 64-bit)
    • Microsoft® Windows® 8.1 Enterprise Edition (both 32- and 64-bit)
    • Microsoft® Windows® 10 Enterprise Edition (both 32- and 64-bit)
    • Mac OS 10.12 Sierra
    • Mac OS 10.13 High Sierra
  • Mobile operating system for PPM Mobility Accelerator

    • Windows Mobile 6.1

    • Blackberry OS 4.6.0.167

    • Symbian OS 9.3

  • Mobile operating system for PPM Mobile Website Client (PPM Apps)

    • iOS 7 (on iPhone 5/5S), or iOS 8 (on iPhone 6/6 plus)

    • Android 4.2 (on Samsung Galaxy S4), or Android 4.4 (on Samsung Galaxy S5)

  • Hardware

    • 1.0 GHz (or faster) processor

    • RAM

    • At least 512 MB

    • For PPM Workbench, at least 1 GB

  • Tablet computer

    The following tablet computer as PPM client:

    • iPad 2 with iOS 5

    • iPad 3 with iOS 5.1

    • iPad 4 with iOS 6

    • HP ElitePad
    • iPad 4 with iOS 10
  • Adobe® Acrobat Reader 5.0 (or later)

  • Browsers

    • Microsoft Internet Explorer 11 (standard mode only) on Windows 7~10 Enterprise Edition
    • Safari 10.1.2 on Mac OS 10.12 and 10.13

    • Mozilla Firefox 52.7.3 Extended Support Release (ESR) on Windows 7~10 Enterprise Edition
    • Google Chrome 66 on Windows 7~10 Enterprise Edition

    Note:  

    • For Firefox, PPM certifies ESR versions only. See https://www.mozilla.org/en-US/firefox/organizations/faq/ for Firefox ESR overview.
    • For Google Chrome, PPM 9.50 certifies version 66 only. However, PPM is committed to investigating the reported issue on non-certified later versions.

Multilingual User Interface Support

To support the languages listed in An Overview of Language Support, clients should be configured with at least one of the languages as that installed on the PPM instance.

For example, if your PPM instance has only the French language pack installed, all clients that access this instance should be configured to use French.