IBM Platforms

Operating System

Requirements

Additional Information

Platform

IBM AIX version 6.1

All of the following:

  • POWER4TM / POWER5TM / POWER7® (both 32- and 64-bit)
  • 2 GB RAM
  • 1 GB disk space
  • 400 MB temp space
  • 300 MB on root partition (for installation only

The following operating system filesets are required for AIX 6.1:

  • bos.adt.base
  • bos.adt.lib
  • bos.adt.libm
  • bos.perf.libperfstat 6.1.2.1 or later
  • bos.perf.perfstat
  • bos.perf.proctools
  • xlC.aix61.rte.10.1.0.0 or later
  • xlC.rte.10.1.0.0 or later
  • gpfs.base 3.2.1.8 or later
  • These are minimum requirements—faster processors and additional memory and storage are acceptable.
  • See Hardware Sizing Estimates for additional considerations.

IBM AIX version 7.1

All of the following:

  • POWER4TM / PPC970 / POWER5TM / POWERR6 / POWER7 (both 32- and 64-bit)
  • 2 GB RAM
  • 1 GB disk space
  • 400 MB temp space
  • 300 MB on root partition (for installation only

The following operating system filesets are required for AIX 7.2:

  • bos.adt.base
  • bos.adt.lib
  • bos.adt.libm
  • bos.perf.libperfstatr
  • bos.perf.perfstat
  • bos.perf.proctools
  • xlC.aix61.rte.13.1.0.1 or later
  • xlC.rte.10.1.0.0 or later
IBM AIX version 7.2

All of the following:

  • POWER4TM / PPC970 / POWER5TM / POWER6® / POWER7® (both 32- and 64-bit)
    2 GB RAM 1 GB disk space 400 MB temp space 300 MB on root partition (for installation only The following operating system filesets are required for AIX 7.1: bos.adt.base bos.adt.lib bos.adt.libm bos.perf.libperfstat bos.perf.perfstat bos.perf.proctools xlC.aix61.rte:13.1.0.1 or later xlC.rte.13.1.0.1 or later

JDK Software

All IBM operating systems previously identified in this table

The following:

  • Java SE Version 7.0 Service Refresh 2 or later SR ( 32-bit and 64-bit) (available from IBM)
    (Recommended: 7.0 Service Refresh 7 Fix Pack 1)

Caution: It is recommended that you upgrade JDK to the latest update according to the vendor's security suggestions.

 
Communications Software
All Microsoft operating systems previously identified in this table

One of the following:

  • Internet Protocol version 4 (IPv4) (default)
  • Internet Protocol version 6 (IPv6)

To enable support for IPv6, add the ENABLE_IPV6 parameter to the server.conf file and set it to true. For more information, see the Installation and Administration Guide.

Secure Communications Software

All IBM operating systems previously identified in this table

One of the following:

  • OpenSSH version 5.9
  • OpenSSH version 6.9
  • Reflection for Secure IT for Unix v7.1
 

Terminal Emulation Software

All IBM operating systems previously identified in this table

One of the following:

  • "Dumb" mode
  • VT100 mode
  • VT220 mode
 

Other Software

All IBM operating systems previously identified in this table

One of the following:

  • SQL*Net
  • SQL*Plus
  • The Oracle client version should correspond to the version of the database used with the PPM instance.
  • SQL*Net must be configured to recognize the connection string of the Oracle database that contains the PPM database schema.
  • Oracle Java virtual machine (OracleJVM) must be enabled for PPM. For more information, see the Installation and Administration Guide or the Upgrade Guide.

All IBM operating systems previously identified in this table

(Optional) The following:

  • Email application configuration

If you are planning to use notifications, an email application is needed. See Email Server Requirements for details.

All IBM operating systems previously identified in this table

The following:

  • Bourne shell

The Bourne shell is available by default on most UNIX systems. However, in some environments, it might be not configured or enabled. Check with your UNIX system administrator to make sure that the Bourne shell is available and configured on your system.