PPM Database Requirements

The following Oracle database versions are supported on all PPM Server platforms:

  • Oracle 11.2.0.2, Standard and Enterprise Edition (RAC and Non-RAC)

  • Oracle 11.2.0.3, Standard and Enterprise Edition (RAC and Non-RAC)

  • Oracle 11.2.0.4, Standard and Enterprise Edition (RAC and Non-RAC)

  • Oracle 12.1.0.1, Standard and Enterprise Edition (RAC and Non-RAC)
  • Oracle 12.1.0.2, Standard and Enterprise Edition (RAC and Non-RAC)

  • Oracle 12.2.0.1, Standard and Enterprise Edition (RAC and Non-RAC)

Note: For the production environment only, PPM 9.40 can run on Oracle 12c with Container Database (CDB) or Pluggable Database (PDB) enabled.

Note: There is a known issue in the Oracle 12 side. To address this issue, you should permanently alter the session parameter "optimizer_adaptive_features".

  • To do so:

    1. Log on to PPM database schema as PPM_SCHEMA.
    2. Run the commands as follows:

      create trigger PPM_LOGON_ORACLE_18311854
      after logon on <PPM_SCHEMA_NAME>.schema
      begin
      execute immediate 'alter session set "optimizer_adaptive_features" = false';
      end;

Note: Because Oracle Enterprise DB Server is not supported on VMware, PPM does not work with Oracle Enterprise DB Server on VMware.

For sizing information for database-based DMS solutions, see Database Sizing.

For details about server requirements, see Oracle documentation specific to your operating system in the Oracle Database Documentation Library
(http://www.oracle.com/pls/db112/portal.portal_db?selected=11&frame=).

For information on periodic database maintenance tasks, see the Oracle Database Administrator's Guide.

Database Character Sets

The table below lists the database character sets supported for English-language deployments of this version of PPM.

Code

Description

US7ASCII

ASCII 7-bit U.S. America

WE8ISO8859P1

ISO 8859-1 Western Europe

WE8ISO8859P9

ISO 8859-9

WE8ISO8859P15

ISO 8859-15

WE8MSWIN1252

Microsoft Windows code page 1252 8-bit Western Europe

Note: Supported for legacy reasons. Do not use for new PPM installations.

UTF8

Unicode 3.0 UTF-8

AL32UTF8

Unicode 3.0 UTF-8

Note: For new PPM installations, make sure you ALWAYS use AL32UTF8.

You should also specify:

  • AL32UTF8 for NLS_CHARACTERSET

  • AL16UTF16 for NLS_NCHAR_CHARACTERSET

Note: We strongly recommend the use of AL32UTF8 for new installations.