Upgrading Integrations

Integrations with Application Lifecycle Management

If you upgrade your PPM instance to version 9.50, and you then upgrade an integrated Quality Center version 10.00 instance to Application Lifecycle Management version 11.00 or later, existing integrations of PPM requests and Quality Center entities (defects or requirements) on that instance are not upgraded. Integrations that you reestablish operate as new integrations.

Caution: If you deployed the ALM content bundle on PPM version 9.12 or earlier, and configured any integration solutions using the ALM entities provided, unless advised otherwise, we strongly recommend you keep using the old ALM content bundle to avoid any potential data loss with your integration solutions.

There is no need to deploy a new ALM content bundle, regardless of which version of PPM you upgrade to.

For detailed instructions on how to upgrade an integrated Quality Center version 10.00 instance to Application Lifecycle Management version 11.00 or later, see the Solution Integrations Guide.

Integrations with Service Manager

For the integration between PPM requests and Service Manager changes, you need to generate Web service stubs for new installations of ALM content bundle and after any upgrade of PPM.

For instructions of generating Web service stubs, see Solution Integrations Guide.

Upgrading Custom Integrations

If you have custom integrations that can be used to update PPM version 9.50 data, make sure that you perform the updates using a supported method. Using SQL to update the data directly in the database is very risky and could corrupt the data. Micro Focus strongly discourages direct updates to the database tables.