Plugin issues

This topic helps you troubleshoot plugin-related issues in PulseUno.

PMD plugin

  • If the compilation unit (*.java file) is not syntactically correct, PMD does not report any findings. Therefore, sources must be compiled successfully.

  • If the compilation unit (*.java file) is very large, for example, 10,000 lines, and there are multiple bugs, PMD may take a long time to complete.

For details about the PMD plugin, see PMD.

SonarQube plugin

If you have problems with SonarQube Scanner, see the SonarQube help.

If you receive the Stopped state, verify that:

  • The plugin property file is in this location:

    ${dataDir}/conf/experts/com.serena.starlight/sonarqube/sonarqube-pulse-expert.properties

  • All required properties are specified in the property file.

  • The SonarQube server and database are up and running.

  • The connection details to the SonarQube server and SonarQube database are configured correctly in the property file.

  • The path to the SonarQube Runner command-line tool is correct in the property file.

Check the PulseUno log file.

For details about the SonarQube plugin, see SonarQube.

Back to top

Deployment Automation plugins

If you have issues with the Deployment Automation plugins, verify the following:

  • The configuration is set up properly. For example, the correct names of Deployment Automation entities are specified.

  • If the property file is not found or is not set up correctly, the wrong Deployment Automation server URL may be specified.

  • The Deployment Automation server version is supported.

  • The Deployment Automation agent or resource is online.

For details about the Deployment Automation plugins, see the following topics:

Back to top

Dependency Vulnerabilities plugin

If you have issues with the Dependency Vulnerabilities plugin, verify the setting for the autoupdate property in the properties file. If the autoupdate property is set to false, CVE data is not updated, and the plugin will not report any findings.

For details about the Dependency Vulnerabilities plugin, see Dependency Vulnerabilities.

Back to top

See also: