Version compatibility

This section contains information about the compatibility of scripting tools, protocols, monitors, and other assets used by StormRunner Load. It also lists the browsers and versions in which StormRunner Load is supported.

Note: We recommend that you use the most up-to-date, supported version.

Scripting tools

The following table lists the tools you can use to create scripts for your load tests:

Scripting Tool Supported Version
LeanFT 14.52
TruClient 12.00-12.63
VuGen 12.00-12.63

Back to top

Protocols

The following table lists the protocols that are supported in StormRunner Load load tests:

Protocol Supported Version
Citrix 4.x and later
ERP
  • Oracle - JInitiator 1.3.1.18

  • JInitiator 1.1.8.1

  • SAP 7.40, 7.50

Flex Flex, SDK 4.6, AMF0, AMF3, RTMPT, RTMP, RTMPS
Gatling 2.17
Java 1.6 - 1.10
JMeter 2.11-5.1.1
Mobile Web (HTTP/HTML) LoadRunner 12.00-12.62
MQTT 3.1
Selenium 3.2
TruWeb 12.60-12.63
.Net 2.3, 3.5, 3.5 SP1, 4, 4.5, 4.6, 4.6.1, 4.6.2

Back to top

Monitors

The following table lists the monitors supported by StormRunner Load:

Monitor Supported Version
AppDynamics SaaS
Dynatrace SaaS
Dynatrace on-premises 6.5 and later
New Relic SaaS
SiteScope SaaS
SiteScope on-premises 11.33

For details on working with monitors, see Monitors.

Back to top

On-premises load generators

While we strongly recommend that you use the current version of the on-premises load generator (version 3.6), StormRunner Load does support up to two versions back (3.5, 3.4).

The following table shows the compatibility between StormRunner Load on-premises load generators and LoadRunner:

OPLG version LoadRunner version
3.6 12.63
3.5 12.62
3.4 12.62

For details on working with on-premises load generators, see On-premises load generators

Note: For details of the supported Mobile Center versions, refer to the My product matrix page in the Mobile Center Help Center. Look for the Mobile Center version associated with the VuGen/TruClient version in use.

Back to top

CI tools

StormRunner Load supports the following CI tools:

CI Tool Version
Bamboo 5.9, 10-6.x
Jenkins Jenkins Server 2.60.3 and later
TFS-VSTS TFS Server 2018

For details on working with CI tools, see CI Tools.

Back to top

Supported browsers

We support the two most recent versions of the following browsers, but strongly recommend using the latest version.

OS Browser
Windows

Chrome

Firefox

Linux

Chrome

Firefox

MAC

Chrome

Safari

Note: If you work in Compatibility mode, StormRunner Load may behave unexpectedly.

Back to top

Screen resolutions

Recommended: 1920 x 1080

Supported: 1024 x 768

Back to top