Manage Virtualization Projects

This task describes how to create and manage virtualization projects.

Note: To learn more about Service Virtualization projects, see Virtualization Projects.

Create a new project

Select one of the following:

  • Select a task from the Get Started page. These tasks first create a new virtualization project and then a new virtual service. For user interface details, see Start Page.
  • Create a new virtualization project. From the main menu, select File > New > Virtualization Project. For user interface details, see Summary of Virtualization Project Dialog Box.

Back to top

Add projects to an existing solution

You can add new or existing projects to a solution.

  1. From the main menu, select View > Projects to display the Projects pane.
  2. Right-click the solution name and select one of the following:

    1. Add > New Virtualization Project
    2. Add > Existing Project

Back to top

Open a project

To open a project, select one of the following:

  • On the Start Page, under Recent Projects, select a project.

    Tip: Hover over a project name to see the full path to the saved project.

  • From the main menu, select File > Open Project/Solution. By default, projects are stored in the following location in the file system: <Your Documents folder>\HPE Service Virtualization\Projects.

Back to top

Change the default project location

From the main menu, select Tools > Options > General tab. Then select Projects and Solutions.

Back to top

Close a project

From the main menu, select File > Close Project/Solution.

Back to top

View server information

In the Virtualization Explorer, expand a project. The server is displayed as the last item in the tree. Click the server to display its details in the lower pane.

Back to top

Move virtual services to a different server

The virtual services in your project are deployed on the Service Virtualization server specified for the project.

To change the server:

  1. In the Virtualization Explorer, expand a project.
  2. Right-click the server and select Change Server.

Alternatively, from the main menu, select Project > Change Server.

For user interface details, see Change Server Dialog Box.

Back to top

Export a project

Save your project as an archive file in the file system. From the main menu, select File > Export Project. The file is saved with the default file extension .vproja.

Back to top

Encrypt projects

You can encrypt your projects using a password you define.

  1. From the main menu, select Tools > Options.
  2. On the General page, click Projects and Solutions and enter a project encryption password.

For more details on encryption, see Password Encryption.

Back to top