Support Matrix

The following environments are supported for Service Virtualization 5.3:

Protocols

Service

Protocol

Metadata

Supported Version

Supported Server

Comments

REST

Binary / Text

Y

 

 

Also supported on Android and iOS devices

 

 

 

XML

Y

 

 

 

JSON/JSONP

Y

 

 

HTTP

SOAP

N

 

 

 

Binary / Text

Y

 

 

 

XML

Y

 

 

 

IBM WebSphere MQ

Binary / Text

Y

 

7.0<=x<=9.0

Non-Intrusive* and Intrusive approach supported

XML

Y

 

COBOL

Y

 

Fixed-Length

Y

 

SOAP

Y

 

FIX

Y

 

SWIFT MT/MX

Y

 

CSV

Y

 

TIBCO EMS 

TIBCO EMS 

SOAP

 

5.1, 6.0

Libraries for client copied from server installation

 

Binary / Text

 

 

XML

 

JMS

SOAP

N

 

WebLogic 11, JBoss 6, WebSphere 7

Supports HTTP, HTTPS

Supported servers lists includes only tested app servers but should work with any J2EE server

Binary / Text

Y

 

 

XML

Y

 

 

IMS

COBOL

Y

 

 

 

Binary

N

 

 

 

CICS

COBOL / HTTP

Y

 

 

 

Binary / HTTP

Y

 

 

 

COBOL / CICS TG SDK (TCP) Y      

JDBC

JDBC

Y

JDBC3, JDBC4

Oracle, DB2, MSSQL

JDBC

SAP

RFC

Y

SAP R/3 Enterprise Central Component 6.0, SAP R/3 Enterprise Central Component 6.0 Enhancement Package 4

SAP

 

IDOC

Y

 

 

 

Oracle AQ

XML, UDT

N

Oracle 11g

Oracle 11g

 

Microsoft MQ

Binary / Text

Y

 

 

 

XML

Y

 

 

 

TCP

Fixed Length

N

 

 

 

webMethods Flow Service

Generic

Y

webMethods Integration Server

 

 

SAP RFC

Y

 

 

 

SAP IDOC

Y

 

 

 

ISO 8583

ISO 8583/Binary

N

1987 1993 2003

 

 

Filesystem

CSV

N

 

 

 

Binary

N

 

 

 

XML

N

 

 

 

Test Delimited

N

 

 

 

Fixed-Length

N

 

 

 

FTP/FTPS/SFTP

CSV

N

 

 

 

Binary

N

 

 

 

XML

N

 

 

 

Test Delimited

N

 

 

 

Fixed-Length

N

 

 

 

Java

Java

N

Java 1.6+

 

 

Mobile API (Android)

BLE GATT

N

Android 5.0 +

 

 

NFC HCE

N

 

 

*IBM WebSphere MQ Non-Instrusive tested combinations

MQS Operating System

Core

LE/BE

MQ Version

Linux Red Hat 6.4

Intel x64

LE

7.0.1.3

Oracle Solaris 5.10

Intel x64

LE

7.0.1.3

Linux Red Hat 5.8

Intel x64

LE

7.0.1.3

IBM AIX 5.3

IBM Power PC5

BE

7.0.1.3

Microsoft Windows 2008 R2

Intel x64

LE

7.5.0.2

Oracle Solaris 5.10

Oracle SPARC

BE

8.0.0.0

HP HPUX B.11.31

HP Itanium

BE

7.0.1.3

Linux RHEL 5.11

Intel x64

LE

7.5.0.0

Back to top

Operating systems

Operating System

Supported Edition or SP

Designer

Server

Comments

Windows 10 64-bit

 

Yes

Yes

 

Windows 8.1 64-bit

 

Yes

Yes

 

Windows Server 2019   Yes Yes  

Windows Server 2016

 

Yes

Yes

 

Windows Server 2012 R2

 

Yes

Yes

 

Windows Server 2012

 

Yes

Yes

 

Oracle Linux 7.3

 

No

Yes

Service Virtualization Server only (not the Designer)

CentOS Linux 7

 

No

Yes

Service Virtualization Server only (not the Designer)

Red Hat Enterprise Linux 7.3

 

No

Yes

Service Virtualization Server only (not the Designer)

Back to top

Java runtime for SV Lab

Java 8 JRE or later from one of the following:

  • OpenJDK 8u112
  • Oracle Java 1.8.0.111

Back to top

Database types

Supported DB type

Database version

Designer on Windows

Server on Windows

Server on Linux

MS SQL

2008 R2 Express

x

x*

-

2008 R2 Server

x

x

-

2012 Express

x

x*

-

2012 Server

x

x

-

2014 Express

x

x*

-

2014 Server

x

x

-

2016 Express

x

x*

x*

2016 Server

x

x

x

Azure SQL

x

x

x

Oracle

11 g

x

x

x

12 c

x

x

x

PostgreSQL

9.x, 10.x and later

x

x

x

* Express editions of MS SQL Server may not be suitable for larger deployments or performance testing.

Back to top

Compatibility with Micro Focus solutions

Solution

Version

Comments

ALM

11.52 and later

 

UFT

14.52 and later

 

LoadRunner Professional

12.62 and later

 

LoadRunner Enterprise

12.62 and later

 
UFT Mobile 3.4 Embedded SV Lab 5.3
UFT Developer 15.0 Embedded SV Lab 5.2

Silk Test

20.5

Embedded SV Lab 5.2

Back to top

Compatibility with non-Micro Focus solutions

Supported AD solutions

Comments

Application Automation Tools Jenkins Plugin

https://github.com/jenkinsci/hpe-application-automation-tools-plugin/blob/latest/doc/README.md

App Delivery Management Bamboo CI Plugin

https://marketplace.atlassian.com/apps/1217829/app-delivery-management-bamboo-ci-plugin

Back to top

Virtualization

Supported Versions

Designer

Server

VMware ESX 4.0 or later

Yes

Yes*

VM Workstation 5.5 or later

Yes

Yes*

* We do not recommend running the SV Server for load testing, on a virtual environment.

Back to top

Supported browsers

Supported Browser

Browser versions

Google Chrome

 

Mozilla Firefox

 

Microsoft Edge

 

Microsoft Internet Explorer

10, 11 (requires compatibility mode to be turned off)

Apple Safari

 

Back to top