Working with Application Lifecycle Management

This section describes how to manage your Vuser scripts by integrating with Application Life Cycle Management.

Managing Scripts Using ALM - Overview

VuGen works together with Application Lifecycle Management (ALM). ALM provides efficient functionality for storing and retrieving Vuser scripts, scenarios, and analysis results. You can store scripts in an ALM project and organize the scripts into unique groups.

In order for VuGen to access an ALM project, you must connect VuGen to the Web server on which the ALM project is located. You can connect to either a local or remote Web server.

For details on working with ALM, see the ALM Help Center.

Back to top

Connect to ALM

To store and retrieve scripts from ALM, you need to connect to an ALM project. You can connect or disconnect from an ALM project at any time during the testing process.

You can connect to one version of ALM from VuGen and a different version from your browser. For more information, see the Important Information section in ALM Connection Dialog Box [VuGen].

To connect to a project in ALM:

  1. Determine the type of authentication required for the ALM server: User name/password or CAC (Common Access Card). For CAC mode, enable CAC authentication in VuGen's General options. For details, see General Options Tab.

  2. Select Version Control > ALM > ALM Connection. The ALM Connection dialog box opens.

  3. In the Step 1: Connect to server section, enter a user name and password (not relevant for CAC authentication) and click Connect. VuGen connects to the ALM server.

    To disconnect from ALM, click Disconnect.

  4. In the Step 2: Login to project section, enter the domain and project details, and then click Login. VuGen logs in to the specified project.

    To log out of the project, click Logout.

  5. Click Close to close the ALM Connection dialog box.

Note: If you authenticated through CAC mode and disconnected from the ALM server, you need to restart VuGen before reconnecting in CAC mode.

Back to top

ALM Version Control - Overview

VuGen supports version control features in Vuser scripts saved in ALM projects that use version control.

The version control features change the process of opening and saving a script. Scripts with version control are either in a state of checked-in or checked-out. When you are working with a script in a checked-out state, any changes you make will not be saved on the ALM server until you check in the script. If you save the script from within VuGen, a temporary file is saved on your machine that protects your changes in case your computer crashes.

If you are working with a script in a checked-in state, the script is read-only and you cannot make any changes until you check out the script.

If a particular script is being saved to ALM for the first time, and the project uses version control, the script automatically starts in a checked-out state.

Back to top

Work with Scripts in ALM Projects

The following steps describe the workflow of how to work with Vuser scripts that are saved in an ALM project.

Note: To work with scripts in ALM projects with version control, see Work with Version-Controlled Scripts in ALM Projects.

  1. Connect to ALM

    Open a connection to the ALM server and project that contains the script. For details, see Connect to ALM.

  2. Open the script

    Select File > Open > Script/Solution. In the Open VuGen Script or Solution dialog box, select the script to open and then click Open.

  3. Save the script

    Select File > Save Script. If the script is in a project that uses version control and is not checked out, the script is saved as a temporary file on your local machine.

Back to top

Work with Version-Controlled Scripts in ALM Projects

Relevant for: Scripts in ALM projects that support version control AND have the Performance Center addition installed.

If these two conditions are not met, see Work with Scripts in ALM Projects.

The following steps describe how to work with scripts saved in ALM projects for which version control is enabled.

  1. Connect to ALM.

    Open a connection to the ALM server and project that contains the script. For details, see Connect to ALM.

  2. Open the script.

    Select File > Open > Script/Solution. In the Open VuGen Script or Solution dialog box, select the script to open and then click Open.

  3. Check in/out the script.

    If the ALM project has version control, each script is always defined as being either checked-in or checked-out. For more details, see ALM Version Control - Overview. To check in and check out scripts, select Version Control > ALM > Check In/Check Out.

    Note: If the ALM project has version control, the file is locked when it is checked out.

    If the ALM project is not version controlled, the file is not locked when checked out of the project.

  4. Cancel a check out. (Optional)

    If you checked out a script and do not want to save the changes, you can return the status of the script to checked-in without saving by selecting Version Control > ALM > Undo Check Out.

  5. Save the script.

    Select File > Save Script. If the script is in a project that uses version control and is not checked out, the script is saved as a temporary file on your local machine.

Back to top

Save VuGen Vuser Scripts to ALM Projects

The following steps describe how to save a Vuser script to an ALM project.

  1. Open or create the Vuser script

    Create or open the desired script in VuGen.

  2. Connect to ALM

    Open a connection to the ALM server and project in which you want to store the script. For details, see Connect to ALM.

  3. Save the script to ALM

    1. Select File > Save Script as. The Save Script As dialog box opens.
    2. Click ALM Test Plan, and then specify the name and location for the script.
    3. Click Save. After a short time, the Working Mode dialog box opens.

    4. Select one of the following options:

      Runtime Mode. Copies only the files needed to replay the script. This option does not copy recording snapshot files and other unnecessary files. This results in a shorter transfer time.

      All Files Mode. Copies all of the files associated with this script. This results in a longer transfer time.

Back to top

Compare Previous Versions of a Script

If your Vuser script is saved in an ALM project that uses version control, you can compare previous versions of the script. The following steps describe how to do this.

  1. Connect to ALM

    Open a connection to the ALM server and project that contains the script that you want to view or modify. For details, see Connect to ALM.

  2. Open the script

    Select File > Open > Script/Solution. In the Open VuGen Script or Solution dialog box, select the script to open and then click Open.

  3. Compare previous versions of the script

    1. Select Version Control > ALM > Version History. The Version History dialog box opens.
    2. Select two previous versions of the script and then click Compare Versions. WDiff opens and displays the two versions of the script.

Back to top

ALM Connection Dialog Box [VuGen]

This dialog box enables you to connect to an ALM project from within VuGen.

To access
Version Control > ALM > ALM Connection
Important information
  • You can connect to one version of ALM from VuGen and a different version of ALM from your browser.
  • You can connect to different versions of ALM only if one of the versions is ALM 11.00 or higher.

    Note: Before you connect to results stored on ALM through the this dialog box, it is recommended that you first connect to the ALM server through your browser. This automatically downloads the ALM client files to your computer.

  • You can configure more advanced settings, such as a proxy setting, by using the Webgate Customization tool (webgatecustomization.exe) and then sign into ALM using the ALM Connection Dialog Box. The Webgate Customization tool can be found on your ALM server at the following address: http://<ALM Server>/qcbin/Apps/.

     

User interface elements are described below:

UI Element
Description
Step 1: Connect to Server
  • Server URL. The URL of the server on which ALM is installed.

  • User name. Your ALM project user name (not relevant for CAC authentication).
  • Password. Your ALM project password (not relevant for CAC authentication).
  • . Connects to the server specified in the Server URL box.

  • . Disconnects from the current ALM server.
Step 2: Login to Project
  • Domain. The domain that contains the ALM project. Only those domains containing projects to which you have permission to connect to are displayed.

  • Project. Enter the ALM project name or select a project from the list. The list includes only those projects to which you have permission to connect.

  • . Logs into the ALM project.
  • . Logs out of the current ALM project.
Restore connection on startup Automatically reconnect to the ALM server the next time you start VuGen, using the same credentials.

Back to top